summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorArnel A. Borja <kyoushuu@yahoo.com>2012-09-30 18:33:56 +0800
committerJürg Billeter <j@bitron.ch>2012-11-03 07:37:02 +0100
commitfd2b222a9ad7382bf0f802d50a9702d455195ef3 (patch)
treea7bc28bbdd0bd1f6b4268f71fe3899473d70a89b /Makefile.am
parent3efecce2f21e0cdc97f4633cfda52eb0d9ea1ab8 (diff)
downloadvala-fd2b222a9ad7382bf0f802d50a9702d455195ef3.tar.gz
Fix build for Windows
- Replace POSIX calls for spawning process with functions from Windows API when compiling for Windows - Add EXEEXT to valac and vapigen paths - Remove EXEEXT from scripts Fixes bug 685180.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 3a8fc6c84..12e50df5b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -47,7 +47,7 @@ libvala@PACKAGE_SUFFIX@.pc: libvala.pc
.PHONY: bootstrap
bootstrap: all
find $(top_srcdir) -name "*.vala.stamp" | xargs rm -f
- $(MAKE) $(AM_MAKEFLAGS) all VALAC=$(abs_top_builddir)/compiler/valac V=$V
+ $(MAKE) $(AM_MAKEFLAGS) all VALAC=$(abs_top_builddir)/compiler/valac$(EXEEXT) V=$V
.PHONY: test
test: