summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRico Tzschichholz <ricotz@ubuntu.com>2021-05-12 15:36:33 +0200
committerRico Tzschichholz <ricotz@ubuntu.com>2021-05-17 19:03:24 +0200
commitd3bfaa4ae34c0e6c7a7a9d124e6c3a276c545391 (patch)
tree1ebd6a7d4fc2ce1f9d1be7a652784d15c9972cb1 /Makefile.am
parenta3a9343add89612b70eb59698527bdbc6142bba4 (diff)
downloadvala-d3bfaa4ae34c0e6c7a7a9d124e6c3a276c545391.tar.gz
build: Add --enable-test-ubsan configure option and "test-ubsan" make target
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 336125516..47032fdd7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -52,6 +52,10 @@ test:
test-asan:
cd tests && $(MAKE) $(AM_MAKEFLAGS) check TEST_CFLAGS="$(TEST_CFLAGS) -g3 -fsanitize=address -fno-omit-frame-pointer"
+.PHONY: test-ubsan
+test-ubsan:
+ cd tests && $(MAKE) $(AM_MAKEFLAGS) check TEST_CFLAGS="$(TEST_CFLAGS) -g3 -fsanitize=undefined"
+
#if ENABLE_COVERAGE
.PHONY: coverage coverage-report
coverage: