summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJürg Billeter <j@bitron.ch>2009-02-27 00:30:38 +0100
committerJürg Billeter <j@bitron.ch>2009-02-27 01:09:35 +0100
commit9b336713846b3589fd40d60ab30d2fc6246eeadc (patch)
treee5e70349cc924d3440c1da0a4b2fa23ff96ef64b /Makefile.am
parenta86df3cedfb2bf4ac95719f074de45660605a05a (diff)
downloadvala-9b336713846b3589fd40d60ab30d2fc6246eeadc.tar.gz
Generate ChangeLog from git log
Add gitlog-to-changelog script from gnulib and a dist-hook to generate ChangeLog file when creating tarballs.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 82ed2f505..e816fb0a8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -35,8 +35,22 @@ DIST_SUBDIRS = \
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = vala-1.0.pc
+dist-hook: gen-ChangeLog
+
+gen_start_date = 2009-02-25
+.PHONY: gen-ChangeLog
+gen-ChangeLog:
+ if test -d .git; then \
+ $(top_srcdir)/gitlog-to-changelog \
+ --since=$(gen_start_date) > $(distdir)/cl-t; \
+ rm -f $(distdir)/ChangeLog; \
+ mv $(distdir)/cl-t $(distdir)/ChangeLog; \
+ fi
+
EXTRA_DIST = \
ChangeLog.pre-0-4 \
+ ChangeLog.pre-0-5-7 \
+ gitlog-to-changelog \
MAINTAINERS \
vala-1.0.pc.in \
$(NULL)