summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRico Tzschichholz <ricotz@ubuntu.com>2021-11-26 15:57:47 +0100
committerRico Tzschichholz <ricotz@ubuntu.com>2021-11-26 15:57:47 +0100
commit6783dbaf63c200bc60198f98be08d2ecf0ff3a57 (patch)
tree5f2617d7852b61851ee0442bc0188842fdf6d99d /Makefile.am
parent0a59efbbc6ab859e18c2393d141eb99d66a186db (diff)
downloadvala-6783dbaf63c200bc60198f98be08d2ecf0ff3a57.tar.gz
build: Add "test-update" which passed UPDATE_EXPECTED=1 to refresh c-expected
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 47032fdd7..19aaa219c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -56,6 +56,10 @@ test-asan:
test-ubsan:
cd tests && $(MAKE) $(AM_MAKEFLAGS) check TEST_CFLAGS="$(TEST_CFLAGS) -g3 -fsanitize=undefined"
+.PHONY: test-update
+test-update:
+ cd tests && $(MAKE) $(AM_MAKEFLAGS) check UPDATE_EXPECTED=1
+
#if ENABLE_COVERAGE
.PHONY: coverage coverage-report
coverage: