summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRico Tzschichholz <ricotz@ubuntu.com>2021-05-04 09:21:10 +0200
committerRico Tzschichholz <ricotz@ubuntu.com>2021-05-04 09:21:10 +0200
commit318df95914d5db6a25916972180ab4faee992d19 (patch)
tree521809b58ba6d8eae18e87e9ba024e1cade70df6 /Makefile.am
parent8b8340a4392bdff429b99a465acd96a9630ee6b8 (diff)
downloadvala-318df95914d5db6a25916972180ab4faee992d19.tar.gz
build: Add "test-asan" make target for convenience
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 992f95f51..336125516 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -48,6 +48,10 @@ bootstrap: all
test:
cd tests && $(MAKE) $(AM_MAKEFLAGS) check
+.PHONY: test-asan
+test-asan:
+ cd tests && $(MAKE) $(AM_MAKEFLAGS) check TEST_CFLAGS="$(TEST_CFLAGS) -g3 -fsanitize=address -fno-omit-frame-pointer"
+
#if ENABLE_COVERAGE
.PHONY: coverage coverage-report
coverage: