summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBenedikt Morbach <benedikt.morbach@googlemail.com>2012-01-12 15:17:26 +0100
committerRichard Hughes <richard@hughsie.com>2012-01-17 11:08:18 +0000
commit07a6c353a26689e9907788d29d78f8b5c0212b31 (patch)
tree15976e6807e7cdaf3986a2a121282a17ba537a88 /configure.ac
parent38d65955f4520e13b8490dba9a0a145a95bc37fc (diff)
downloadupower-07a6c353a26689e9907788d29d78f8b5c0212b31.tar.gz
Install a systemd service file if systemd is used
This makes dbus defer starting upowerd to systemd instead of doing it itself and thus puts the daemon under proper systemd supervision. Signed-off-by: Richard Hughes <richard@hughsie.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 85ff22e..4d04cdc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -210,6 +210,14 @@ fi
AM_CONDITIONAL(HAVE_IDEVICE, [test x$have_idevice = xyes])
+# systemd
+AC_ARG_WITH([systemdsystemunitdir],
+ AS_HELP_STRING([--with-systemdsystemunitdir=DIR], [Directory for systemd service files]),
+ [],
+ [with_systemdsystemunitdir=$($PKG_CONFIG --variable=systemdsystemunitdir systemd)])
+AC_SUBST([systemdsystemunitdir], [$with_systemdsystemunitdir])
+AM_CONDITIONAL(HAVE_SYSTEMD, [test -n "$with_systemdsystemunitdir"])
+
# export to Makefile.am
AM_CONDITIONAL(BACKEND_TYPE_DUMMY, [test x$with_backend = xdummy])
AM_CONDITIONAL(BACKEND_TYPE_LINUX, [test x$with_backend = xlinux])