summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBastien Nocera <hadess@hadess.net>2021-09-02 18:02:22 +0200
committerBastien Nocera <hadess@hadess.net>2021-09-06 14:06:40 +0200
commit9b93b6c402b901756f07401b3c8443329053b157 (patch)
tree8698addc71b8895b2aed961889eb66f26e66846a /Makefile.am
parent6b9134c5d4494e55be8adc8b7ff842d73ce93a4c (diff)
downloadupower-9b93b6c402b901756f07401b3c8443329053b157.tar.gz
build: Remove autotools
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am63
1 files changed, 0 insertions, 63 deletions
diff --git a/Makefile.am b/Makefile.am
deleted file mode 100644
index e64060c..0000000
--- a/Makefile.am
+++ /dev/null
@@ -1,63 +0,0 @@
-## Process this file with automake to produce Makefile.in
-
-ACLOCAL_AMFLAGS = -I m4 ${ACLOCAL_FLAGS}
-
-SUBDIRS = etc dbus libupower-glib src doc tools po
-
-if BACKEND_TYPE_LINUX
-SUBDIRS += rules
-endif
-
-# Creating ChangeLog from git log (taken from cairo/Makefile.am):
-ChangeLog: $(srcdir)/ChangeLog
-
-$(srcdir)/ChangeLog:
- @if test -d "$(srcdir)/.git"; then \
- (cd "$(srcdir)" && \
- ./missing --run git-log --stat) | fmt --split-only > $@.tmp \
- && mv -f $@.tmp $@ \
- || ($(RM) $@.tmp; \
- echo Failed to generate ChangeLog, your ChangeLog may be outdated >&2; \
- (test -f $@ || echo git-log is required to generate this file >> $@)); \
- else \
- test -f $@ || \
- (echo A git checkout and git-log is required to generate ChangeLog >&2 && \
- echo A git checkout and git-log is required to generate this file >> $@); \
- fi
-
-EXTRA_DIST = \
- HACKING \
- ChangeLog
-
-MAINTAINERCLEANFILES = \
- ABOUT-NLS \
- aclocal.m4 \
- build-aux \
- ChangeLog \
- config.h.in \
- gtk-doc.make \
- po/Makefile.in.in~ \
- po/Makevars.template \
- po/Rules-quot \
- po/e*.header \
- po/*.sin \
- po/*.sed \
- *.tar.xz \
- INSTALL
-
-snapshot:
- $(MAKE) dist distdir=$(PACKAGE)-$(VERSION)-`date +"%Y%m%d"`
-
-pkgconfigdir = $(libdir)/pkgconfig
-pkgconfig_DATA = upower-glib.pc
-
-# xsltproc barfs on 'make distcheck'; disable for now
-DISTCHECK_CONFIGURE_FLAGS=--enable-man-pages --enable-gtk-doc \
- --with-systemdsystemunitdir=$$dc_install_base/$(systemdsystemunitdir) \
- --with-udevrulesdir='$${libdir}/udev/rules.d-distcheck' \
- --enable-introspection=yes
-
-clean-local :
- rm -f *~
-
--include $(top_srcdir)/git.mk