summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBastien Nocera <hadess@hadess.net>2018-10-25 13:02:22 +0200
committerBastien Nocera <hadess@hadess.net>2018-10-25 13:12:35 +0200
commit8913f60347802077881c4829c3c10ee589b0870f (patch)
tree1107d005ee085577948cae595d7187cbd4cace3a /Makefile.am
parent7c17075ac04a10e2727a63e5c973c142b077ba1f (diff)
downloadupower-8913f60347802077881c4829c3c10ee589b0870f.tar.gz
doc: Fix dist not working
automake's documentation says that it works depth-first, but it doesn't actually go depth first when dist'ing a directory. So our .ref.xml files aren't generated when we try to get them added to the dist. Fix this with a big hammer by moving the generation to the current directory, rather than spending any more time working with automake. Can't wait for the meson port.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 13dc902..559c4f9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -52,7 +52,7 @@ pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = upower-glib.pc
# xsltproc barfs on 'make distcheck'; disable for now
-DISTCHECK_CONFIGURE_FLAGS=--disable-man-pages --enable-gtk-doc \
+DISTCHECK_CONFIGURE_FLAGS=--enable-man-pages --enable-gtk-doc \
--with-systemdsystemunitdir=$$dc_install_base/$(systemdsystemunitdir) \
--with-udevrulesdir='$${libdir}/udev/rules.d-distcheck'