summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBenedikt Morbach <benedikt.morbach@googlemail.com>2012-01-12 15:17:26 +0100
committerRichard Hughes <richard@hughsie.com>2012-01-17 11:08:18 +0000
commit07a6c353a26689e9907788d29d78f8b5c0212b31 (patch)
tree15976e6807e7cdaf3986a2a121282a17ba537a88 /Makefile.am
parent38d65955f4520e13b8490dba9a0a145a95bc37fc (diff)
downloadupower-07a6c353a26689e9907788d29d78f8b5c0212b31.tar.gz
Install a systemd service file if systemd is used
This makes dbus defer starting upowerd to systemd instead of doing it itself and thus puts the daemon under proper systemd supervision. Signed-off-by: Richard Hughes <richard@hughsie.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index ee9ec84..d03baf7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -52,7 +52,8 @@ pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = upower-glib.pc
# xsltproc barfs on 'make distcheck'; disable for now
-DISTCHECK_CONFIGURE_FLAGS=--disable-man-pages --enable-gtk-doc
+DISTCHECK_CONFIGURE_FLAGS=--disable-man-pages --enable-gtk-doc \
+ --with-systemdsystemunitdir=$$dc_install_base/$(systemdsystemunitdir)
clean-local :
rm -f *~