summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHeinrich Schuchardt <xypron.glpk@gmx.de>2019-09-16 18:41:42 +0200
committerTom Rini <trini@konsulko.com>2019-09-19 12:54:30 -0400
commit282ed24fb3ca8ddb37e9fb465452267e6a658233 (patch)
treedd72430a1424d345ca17c2f6277707160dc23ab4
parent1e3966394a96fbf6128a875d135e074656d1bd64 (diff)
downloadu-boot-WIP/2019-09-19-master-imports.tar.gz
dm: MIGRATION: Add migration plan for CONFIG_DMWIP/2019-09-19-master-imports
For many sub-systems we already require the driver model to be used. Yet there is still a handful of boards that do not have CONFIG_DM enabled. We should make CONFIG_DM compulsory with release v2020.01 Conversion dates for CONFIG_DM_SPL and CONFIG_DM_TPL are yet to be defined. Signed-off-by: Heinrich Schuchardt <xypron.glpk@gmx.de> Reviewed-by: Simon Glass <sjg@chromium.org>
-rw-r--r--Makefile8
-rw-r--r--doc/driver-model/migration.rst10
2 files changed, 18 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 57d0700227..ffc2c4b3e4 100644
--- a/Makefile
+++ b/Makefile
@@ -940,6 +940,14 @@ ifneq ($(CONFIG_DM_SPI)$(CONFIG_OF_CONTROL),yy)
endif
endif
endif
+ifneq ($(CONFIG_DM),y)
+ @echo >&2 "===================== WARNING ======================"
+ @echo >&2 "This board does not use CONFIG_DM. CONFIG_DM will be"
+ @echo >&2 "compulsory starting with the v2020.01 release."
+ @echo >&2 "Failure to update may result in board removal."
+ @echo >&2 "See doc/driver-model/migration.rst for more info."
+ @echo >&2 "===================================================="
+endif
ifeq ($(CONFIG_MMC),y)
ifneq ($(CONFIG_DM_MMC)$(CONFIG_OF_CONTROL)$(CONFIG_BLK),yyy)
@echo >&2 "===================== WARNING ======================"
diff --git a/doc/driver-model/migration.rst b/doc/driver-model/migration.rst
index fd499fb74a..d1fc0e6a78 100644
--- a/doc/driver-model/migration.rst
+++ b/doc/driver-model/migration.rst
@@ -7,6 +7,16 @@ U-Boot has been migrating to a new driver model since its introduction in
2014. This file describes the schedule for deprecation of pre-driver-model
features.
+CONFIG_DM
+---------
+
+* Status: In progress
+* Deadline: 2020.01
+
+Starting with the 2010.01 release CONFIG_DM will be enabled for all boards.
+This does not concern CONFIG_DM_SPL and CONFIG_DM_TPL. The conversion date for
+these configuration items still needs to be defined.
+
CONFIG_DM_MMC
-------------