summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRasmus Villemoes <rasmus.villemoes@prevas.dk>2019-08-28 11:00:46 +0000
committerTom Rini <trini@konsulko.com>2019-08-30 14:17:11 -0400
commit4831e3f685e7bdfa3e2b3cde859be11973f69765 (patch)
treef5ff4b95ab0ee1853f57353dabecde12c45b5844
parent6da39ed37ba84a3376a736da06daa2596c9c8afa (diff)
downloadu-boot-WIP/2019-08-30-master-imports.tar.gz
Makefile: fix newline escaping for CONFIG_DEFAULT_ENV_FILEWIP/2019-08-30-master-imports
I wanted this to be compatible with mkenvimage, including the ability to embed newlines in variables by escaping them. But I failed to check that it works more than once. Fixes: f3d8f7dd73a (Allow providing default environment from file) Signed-off-by: Rasmus Villemoes <rasmus.villemoes@prevas.dk>
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 0570d02e5d..c02accfc26 100644
--- a/Makefile
+++ b/Makefile
@@ -1700,7 +1700,7 @@ define filechk_defaultenv.h
(grep -v '^#' | \
grep -v '^$$' | \
tr '\n' '\0' | \
- sed -e 's/\\\x0/\n/' | \
+ sed -e 's/\\\x0/\n/g' | \
xxd -i ; echo ", 0x00" ; )
endef