summaryrefslogtreecommitdiff
path: root/test/cl/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/cl/Makefile.am')
-rwxr-xr-xtest/cl/Makefile.am42
1 files changed, 42 insertions, 0 deletions
diff --git a/test/cl/Makefile.am b/test/cl/Makefile.am
new file mode 100755
index 000000000..b5e72bcbb
--- /dev/null
+++ b/test/cl/Makefile.am
@@ -0,0 +1,42 @@
+#
+# Licensed to the Apache Software Foundation (ASF) under one
+# or more contributor license agreements. See the NOTICE file
+# distributed with this work for additional information
+# regarding copyright ownership. The ASF licenses this file
+# to you under the Apache License, Version 2.0 (the
+# "License"); you may not use this file except in compliance
+# with the License. You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing,
+# software distributed under the License is distributed on an
+# "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+# KIND, either express or implied. See the License for the
+# specific language governing permissions and limitations
+# under the License.
+#
+
+THRIFT = $(top_builddir)/compiler/cpp/thrift
+
+stubs: ../ThriftTest.thrift
+ $(THRIFT) --gen cl ../ThriftTest.thrift
+
+TestServer: make-test-server.lisp
+ $(SBCL) --script make-test-server.lisp
+
+TestClient: make-test-client.lisp
+ $(SBCL) --script make-test-client.lisp
+
+precross: stubs TestServer TestClient
+
+clean-local:
+ $(RM) -r gen-cl
+ $(RM) TestServer
+ $(RM) TestClient
+
+EXTRA_DIST = \
+ implementation.lisp \
+ make-test-client.lisp \
+ make-test-server.lisp \
+ tests.lisp