summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorJames E. King, III <jking@apache.org>2017-03-10 06:14:18 -0500
committerJames E. King, III <jking@apache.org>2017-03-10 06:14:18 -0500
commit9b1544dc21f2d952b91c44e4636e1b9da937002c (patch)
treee24c4565528a298efe9e7c682665d8035ebe0c0b /debian
parentb79396f799fe88d2dae48573f61257aac5b2c09b (diff)
downloadthrift-9b1544dc21f2d952b91c44e4636e1b9da937002c.tar.gz
THRIFT-4110: add libthrift0-dbg debug symbols package to debian build process for symbolic debugging
This closes #1209
Diffstat (limited to 'debian')
-rw-r--r--debian/control11
-rwxr-xr-xdebian/rules3
2 files changed, 13 insertions, 1 deletions
diff --git a/debian/control b/debian/control
index 43e7a0faf..218d21722 100644
--- a/debian/control
+++ b/debian/control
@@ -166,6 +166,17 @@ Description: Thrift C++ library
This package contains the runtime libraries needed for C++ applications
using Thrift.
+Package: libthrift0-dbg
+Architecture: any
+Section: debug
+Depends: ${shlibs:Depends}, ${misc:Depends}, libthrift0 (= ${binary:Version})
+Description: Thrift C++ library debug symbols
+ Thrift is a software framework for scalable cross-language services
+ development. It combines a software stack with a code generation engine to
+ build services that work efficiently and seamlessly.
+ .
+ This package contains the debug symbols for the Thrift C++ runtime libraries.
+
Package: libthrift-dev
Architecture: any
Section: libdevel
diff --git a/debian/rules b/debian/rules
index 53aec3c02..f370325f4 100755
--- a/debian/rules
+++ b/debian/rules
@@ -202,9 +202,10 @@ binary-common:
dh_installexamples
dh_installman
dh_link
+ dh_strip -plibthrift0 --dbg-package=libthrift0-dbg
dh_strip -ppython-thrift --dbg-package=python-thrift-dbg
dh_strip -ppython3-thrift --dbg-package=python3-thrift-dbg
- dh_strip -pthrift-compiler -plibthrift0
+ dh_strip -pthrift-compiler
dh_compress
dh_fixperms
dh_makeshlibs