summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorNobuaki Sukegawa <nsuke@apache.org>2016-09-10 14:02:19 +0900
committerNobuaki Sukegawa <nsuke@apache.org>2016-09-26 01:42:01 +0900
commit11da87e6f30c237869a09e28ab44fe4a59db270e (patch)
tree4c81e09a6c5647cf8b4216379c30ec8ec2cb5517 /debian
parent1e3cf9b9fdcf9a7b7ffc18a2e6148465b154e66b (diff)
downloadthrift-11da87e6f30c237869a09e28ab44fe4a59db270e.tar.gz
THRIFT-2835 Add possibility to distribute generators separately from thrift core, and load them dynamically
Client: Compiler Patch: Nobuaki Sukegawa, rebased by dtmuller Also fixed by dtmuller: * Add plugin namespace for erlang language binding * Fix unit test test_const_value * Don't clear type cache with every t_program conversion * Type "wb" may not be supported by popen on non-Windows platforms * Fix constness of AST type signatures
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules6
1 files changed, 3 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index a31881d77..84cba1f10 100755
--- a/debian/rules
+++ b/debian/rules
@@ -42,12 +42,12 @@ build: build-arch build-indep
build-arch: build-arch-stamp
$(CURDIR)/compiler/cpp/thrift build-arch-stamp: configure-stamp
- # Compile compiler
- $(MAKE) -C $(CURDIR)/compiler/cpp
-
# Compile C++ library
$(MAKE) -C $(CURDIR)/lib/cpp
+ # Compile compiler
+ $(MAKE) -C $(CURDIR)/compiler/cpp
+
# Compile C (glib) library
$(MAKE) -C $(CURDIR)/lib/c_glib