summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristopher Friedt <chrisfriedt@gmail.com>2020-01-29 03:03:46 -0500
committerGitHub <noreply@github.com>2020-01-29 08:03:46 +0000
commitf8b004081da0c5006c3a0ce0352b66d2d857405e (patch)
treee9216cc072bdb82a23c21814df98058cf9e3079e /configure.ac
parentcb4c31a0720e5449ac562b65ac7916f583d0cb7f (diff)
downloadthrift-f8b004081da0c5006c3a0ce0352b66d2d857405e.tar.gz
Fix typo for python 3 support
This change simply enables the existing check in configure.ac to function as intended. Signed-off-by: Christopher Friedt <chrisfriedt@gmail.com>
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 64283a8ef..f3f88a715 100755
--- a/configure.ac
+++ b/configure.ac
@@ -325,7 +325,7 @@ AM_CONDITIONAL(WITH_TWISTED_TEST, [test "$have_trial" = "yes"])
have_py3="no"
AX_THRIFT_LIB(py3, [Py3], yes)
if test "$with_py3" = "yes"; then
- if $PYTHON --version 2>&1 | grep -q "Python 2"; then
+ if $PYTHON --version 2>&1 | grep -q "Python 3"; then
AC_PATH_PROGS([PYTHON3], [python3 python3.7 python37 python3.6 python36 python3.5 python35 python3.4 python34])
if test -n "$PYTHON3"; then
have_py3="yes"