summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorpenenin <penenin@users.noreply.github.com>2022-10-07 23:06:44 -0700
committerGitHub <noreply@github.com>2022-10-08 14:06:44 +0800
commited542c63fc4360ef6d397df3cd92d6623d713e1e (patch)
tree31da6f61bbc90cef93a4e48c4a86e024d88770ee /configure.ac
parent0aad2aeb55d43a7236edd0f14ba5867f73629a88 (diff)
downloadthrift-ed542c63fc4360ef6d397df3cd92d6623d713e1e.tar.gz
THRIFT-5646 Check for the presence of Gradle to build the Kotlin library. (#2691)
Client: kotlin
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index a926e3e12..9a71fc7e4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -211,9 +211,10 @@ AM_CONDITIONAL([WITH_JAVA], [test "$have_java" = "yes"])
AX_THRIFT_LIB(kotlin, [Kotlin], yes)
if test "$with_kotlin" = "yes"; then
AX_JAVAC_AND_JAVA
+ AC_PATH_PROG([GRADLE], [gradle])
AC_SUBST(CLASSPATH)
AC_SUBST(GRADLE_OPTS)
- if test "x$JAVA" != "x" && test "x$JAVAC" != "x" ; then
+ if test "x$JAVA" != "x" && test "x$JAVAC" != "x" && "x$GRADLE" != "x" ; then
have_kotlin="yes"
fi
fi