summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSergey Yelin <elinsn@gmail.com>2021-03-23 23:48:02 +0300
committerJens Geyer <jensg@apache.org>2021-03-26 22:19:05 +0100
commiteb0f1175a7e966812e8ddfc44006a7fc8df6102a (patch)
tree7aaa71824cba275c8681db627c99067d11cb5c9f /configure.ac
parent3761f0048d0dcf901b683329b4b29cdbd47708fb (diff)
downloadthrift-eb0f1175a7e966812e8ddfc44006a7fc8df6102a.tar.gz
THRIFT-5377 Remove Erlang R16 support
Client: erl Patch: Sergey Yelin This closes #2357
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac6
1 files changed, 0 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 0dd7a6d45..5abfe498c 100755
--- a/configure.ac
+++ b/configure.ac
@@ -220,15 +220,9 @@ if test "$with_erlang" = "yes"; then
if test -n "$ERL" -a -n "$ERLC" && test "x$REBAR" != "x" ; then
have_erlang="yes"
- # otp_release is simply a number (like "17") for OTP17+ while "R16..." for OTP16 or less.
- # OTP version is currently only used for running tests.
- if $ERL -eval 'erlang:display(erlang:system_info(otp_release)),halt().' -noshell | grep "^\"R" >/dev/null; then
- erlang_otp16_or_less="yes"
- fi
fi
fi
AM_CONDITIONAL(WITH_ERLANG, [test "$have_erlang" = "yes"])
-AM_CONDITIONAL(ERLANG_OTP16, [test "$erlang_otp16_or_less" = "yes"])
AX_THRIFT_LIB(nodejs, [Nodejs], yes)
have_nodejs=no