summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorYuxuan 'fishy' Wang <yuxuan.wang@reddit.com>2022-04-19 14:31:39 -0700
committerYuxuan 'fishy' Wang <fishywang@gmail.com>2022-04-25 16:00:53 -0700
commit8045d82f0d5359cbdc196414f0c1aa4679c4124f (patch)
tree29782b3cd2b3d27a4704dad3b57f47f6cf22bd8f /configure.ac
parent88a45ac77518eafb57db08938ecdf38c5fcf7a31 (diff)
downloadthrift-8045d82f0d5359cbdc196414f0c1aa4679c4124f.tar.gz
Update Go versions used in travis and LANGUAGES.md
Per our support policy, drop support of go 1.16 and add support of go 1.18. Also enable go vet in make check, and fix issues reported by go vet.
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 197d3ae32..624287b27 100755
--- a/configure.ac
+++ b/configure.ac
@@ -372,6 +372,7 @@ if test "$with_go" = "yes"; then
AS_IF([test -n "$GO"],[
ax_go_version="1.4"
ax_go17_version="1.7"
+ ax_go118_version="1.18"
AC_MSG_CHECKING([for Go version])
golang_version=`$GO version 2>&1 | $SED -e 's/\(go \)\(version \)\(go\)\(@<:@0-9@:>@.@<:@0-9@:>@.@<:@0-9@:>@\)\(@<:@\*@:>@*\).*/\4/'`
@@ -391,6 +392,13 @@ if test "$with_go" = "yes"; then
:
go_version_lt_17="no"
])
+ AX_COMPARE_VERSION([$golang_version],[ge],[$ax_go118_version],[
+ :
+ go_version_ge_118="yes"
+ ],[
+ :
+ go_version_ge_118="no"
+ ])
],[
AC_MSG_WARN([could not find Go ])
have_go="no"
@@ -399,6 +407,7 @@ if test "$with_go" = "yes"; then
fi
AM_CONDITIONAL(WITH_GO, [test "$have_go" = "yes"])
AM_CONDITIONAL([GOVERSION_LT_17], [test "$go_version_lt_17" = "yes"])
+AM_CONDITIONAL([GOVERSION_GE_118], [test "$go_version_ge_118" = "yes"])
AX_THRIFT_LIB(swift, [Swift], yes)
have_swift="no"