summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJames E. King, III <jking@apache.org>2017-01-25 20:41:06 -0500
committerJames E. King, III <jking@apache.org>2017-01-25 20:41:06 -0500
commit71eba643ddc10bd2a9f614348567bfc1f63d8d06 (patch)
tree2d72bc7e150e4cf4e1345c3f6633b608ce1d4531 /configure.ac
parentcf254894026988c7aa1e9742117c091f902cc838 (diff)
downloadthrift-71eba643ddc10bd2a9f614348567bfc1f63d8d06.tar.gz
THRIFT-4033 disable thrift compiler plug-in support by default, as the thrift-compiler packaging is not ready for it yet
This closes #1157
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac8
1 files changed, 3 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 0452a1570..6415e3dc4 100755
--- a/configure.ac
+++ b/configure.ac
@@ -552,8 +552,8 @@ fi
AM_CONDITIONAL(WITH_TESTS, [test "$have_tests" = "yes"])
AC_ARG_ENABLE([plugin],
- AS_HELP_STRING([--enable-plugin], [build compiler plugin support [default=yes]]),
- [], enable_plugin=yes
+ AS_HELP_STRING([--enable-plugin], [build compiler plugin support [default=no]]),
+ [], enable_plugin=no
)
have_plugin=yes
if test "$have_cpp" = "no" ; then
@@ -562,9 +562,7 @@ fi
if test "$enable_plugin" = "no"; then
have_plugin="no"
fi
-if test "$have_plugin" = "yes" ; then
- AC_CONFIG_LINKS([compiler/cpp/test/plugin/t_cpp_generator.cc:compiler/cpp/src/thrift/generate/t_cpp_generator.cc])
-fi
+AC_CONFIG_LINKS([compiler/cpp/test/plugin/t_cpp_generator.cc:compiler/cpp/src/thrift/generate/t_cpp_generator.cc])
AM_CONDITIONAL(WITH_PLUGIN, [test "$have_plugin" = "yes"])
AC_ARG_ENABLE([tutorial],