summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJens Geyer <jensg@apache.org>2019-10-19 18:27:35 +0200
committerJens Geyer <jensg@apache.org>2019-10-20 16:21:29 +0200
commit3f3567a1143194712747fff9dd02b2162e2d14dd (patch)
tree36564d5680c36fca18a7d8c9aac296e1f70187ef /configure.ac
parent7199741f440ef7de15e13755ea2371157c8cd298 (diff)
downloadthrift-3f3567a1143194712747fff9dd02b2162e2d14dd.tar.gz
THRIFT-4981 Remove deprecated netcore bindings from the code base
Client: netcore Patch: Jens Geyer This closes #1901
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac27
1 files changed, 8 insertions, 19 deletions
diff --git a/configure.ac b/configure.ac
index ad26ef03f..d5d7ecbc9 100755
--- a/configure.ac
+++ b/configure.ac
@@ -127,7 +127,6 @@ if test "$enable_libs" = "no"; then
with_ruby="no"
with_haskell="no"
with_haxe="no"
- with_dotnetcore="no"
with_netstd="no"
with_perl="no"
with_php="no"
@@ -502,14 +501,14 @@ fi
AM_CONDITIONAL(WITH_HAXE, [test "$have_haxe" = "yes"])
-AX_THRIFT_LIB(dotnetcore, [.NET Core], yes)
-if test "$with_dotnetcore" = "yes"; then
+AX_THRIFT_LIB(netstd, [.NET Core], yes)
+if test "$with_netstd" = "yes"; then
AC_PATH_PROG([DOTNETCORE], [dotnet])
if [[ -x "$DOTNETCORE" ]] ; then
- AX_PROG_DOTNETCORE_VERSION( [2.0.0], have_dotnetcore="yes", have_dotnetcore="no")
+ AX_PROG_DOTNETCORE_VERSION( [2.0.0], have_netstd="yes", have_netstd="no")
fi
fi
-AM_CONDITIONAL(WITH_DOTNET, [test "$have_dotnetcore" = "yes"])
+AM_CONDITIONAL(WITH_DOTNET, [test "$have_netstd" = "yes"])
AX_THRIFT_LIB(d, [D], yes)
@@ -817,7 +816,6 @@ AC_CONFIG_FILES([
lib/js/test/Makefile
lib/json/Makefile
lib/json/test/Makefile
- lib/netcore/Makefile
lib/netstd/Makefile
lib/nodejs/Makefile
lib/nodets/Makefile
@@ -846,7 +844,6 @@ AC_CONFIG_FILES([
test/haxe/Makefile
test/hs/Makefile
test/lua/Makefile
- test/netcore/Makefile
test/netstd/Makefile
test/php/Makefile
test/dart/Makefile
@@ -866,7 +863,6 @@ AC_CONFIG_FILES([
tutorial/hs/Makefile
tutorial/java/Makefile
tutorial/js/Makefile
- tutorial/netcore/Makefile
tutorial/netstd/Makefile
tutorial/nodejs/Makefile
tutorial/dart/Makefile
@@ -919,8 +915,8 @@ if test "$have_rs" = "yes" ; then MAYBE_RS="rs" ; else MAYBE_RS="" ; fi
AC_SUBST([MAYBE_RS])
if test "$have_swift" = "yes" ; then MAYBE_SWIFT="swift" ; else MAYBE_SWIFT="" ; fi
AC_SUBST([MAYBE_SWIFT])
-if test "$have_dotnetcore" = "yes" ; then MAYBE_DOTNETCORE="netcore" ; else MAYBE_DOTNETCORE="" ; fi
-AC_SUBST([MAYBE_DOTNETCORE])
+if test "$have_netstd" = "yes" ; then MAYBE_NETSTD="netstd" ; else MAYBE_NETSTD="" ; fi
+AC_SUBST([MAYBE_NETSTD])
if test "$have_cl" = "yes" ; then MAYBE_CL="cl" ; else MAYBE_CL="" ; fi
AC_SUBST([MAYBE_CL])
@@ -937,8 +933,7 @@ echo "Building C++ Library ......... : $have_cpp"
echo "Building Common Lisp Library.. : $have_cl"
echo "Building D Library ........... : $have_d"
echo "Building Dart Library ........ : $have_dart"
-echo "Building dotnetcore Library .. : $have_dotnetcore"
-echo "Building .NET Standard Library : $have_dotnetcore"
+echo "Building .NET Standard Library : $have_netstd"
echo "Building Erlang Library ...... : $have_erlang"
echo "Building Go Library .......... : $have_go"
echo "Building Haskell Library ..... : $have_haskell"
@@ -1001,13 +996,7 @@ if test "$have_dart" = "yes" ; then
echo " Using Pub ................. : $DARTPUB"
echo " Using Dart version ........ : $($DART --version 2>&1)"
fi
-if test "$have_dotnetcore" = "yes" ; then
- echo
- echo ".NET Core Library:"
- echo " Using .NET Core ........... : $DOTNETCORE"
- echo " Using .NET Core version ... : $DOTNETCORE_VERSION"
-fi
-if test "$have_dotnetcore" = "yes" ; then
+if test "$have_netstd" = "yes" ; then
echo
echo ".NET Standard Library:"
echo " Using dotnet .............. : $DOTNETCORE"