summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorcyy <cyyever@outlook.com>2019-01-05 10:52:48 +0800
committerJames E. King III <jking@apache.org>2019-01-07 08:11:37 -0500
commit0705d9956750b9d61d763c8d8e38bb98e86870eb (patch)
tree3624403eb3e96ee37215544045cfb8eea1babb8a /configure.ac
parente42cf5023e3fc7fddf7e6f897aa1fb7d4a090afc (diff)
downloadthrift-0705d9956750b9d61d763c8d8e38bb98e86870eb.tar.gz
force c++11 in GNU autotools
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac5
1 files changed, 1 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index e04891f36..9885e1b64 100755
--- a/configure.ac
+++ b/configure.ac
@@ -102,10 +102,7 @@ AC_PROG_AWK
AC_PROG_RANLIB
AC_LANG([C++])
-AX_CXX_COMPILE_STDCXX_11([noext], [optional])
-if test "$ac_success" = "no"; then
- CXXFLAGS="$CXXFLAGS -Wno-variadic-macros -Wno-long-long -Wno-c++11-long-long"
-fi
+AX_CXX_COMPILE_STDCXX_11([noext], [mandatory])
AM_EXTRA_RECURSIVE_TARGETS([style])
AC_SUBST(CPPSTYLE_CMD, 'find . -type f \( -iname "*.h" -or -iname "*.cpp" -or -iname "*.cc" -or -iname "*.tcc" \) -printf "Reformatting: %h/%f\n" -exec clang-format -i {} \;')