summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMax-Gerd Retzlaff <m.retzlaff@gmx.net>2022-08-23 17:38:34 +0200
committerJens Geyer <jensg@apache.org>2022-08-30 23:58:57 +0200
commit04057ac28a72ad4001def05a7bc8e13cc640b5ca (patch)
tree44435ef2391b86828f97736cfdecc4e374782404 /configure.ac
parent39fa1854a75e96235e2f50a45546b874da29e756 (diff)
downloadthrift-04057ac28a72ad4001def05a7bc8e13cc640b5ca.tar.gz
Revert "THRIFT-5501 Remove Common Lisp support"
This reverts commit d88d4f93b3390989bd47a43f3941ca7d576750f6.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 23 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 154aaf207..88271e676 100644
--- a/configure.ac
+++ b/configure.ac
@@ -112,6 +112,7 @@ if test "$enable_libs" = "no"; then
have_libs="no"
with_cpp="no"
with_c_glib="no"
+ with_cl="no"
with_java="no"
with_kotlin="no"
with_python="no"
@@ -443,6 +444,16 @@ if test "$with_rs" = "yes"; then
fi
AM_CONDITIONAL(WITH_RS, [test "$have_rs" = "yes"])
+AX_THRIFT_LIB(cl, [Common Lisp], yes)
+have_cl="no"
+if test "$with_cl" = "yes"; then
+ AC_PATH_PROG([SBCL], [sbcl])
+ if test "x$SBCL" != "x"; then
+ have_cl="yes"
+ fi
+fi
+AM_CONDITIONAL(WITH_CL, [test "$have_cl" = "yes"])
+
AX_THRIFT_LIB(haxe, [Haxe], yes)
if test "$with_haxe" = "yes"; then
AC_PATH_PROG([HAXE], [haxe])
@@ -745,6 +756,7 @@ AC_CONFIG_FILES([
compiler/cpp/src/Makefile
compiler/cpp/test/Makefile
lib/Makefile
+ lib/cl/Makefile
lib/cpp/Makefile
lib/cpp/test/Makefile
lib/cpp/thrift-nb.pc
@@ -793,6 +805,7 @@ AC_CONFIG_FILES([
test/Makefile
test/features/Makefile
test/c_glib/Makefile
+ test/cl/Makefile
test/cpp/Makefile
test/erl/Makefile
test/go/Makefile
@@ -809,6 +822,7 @@ AC_CONFIG_FILES([
test/rs/Makefile
tutorial/Makefile
tutorial/c_glib/Makefile
+ tutorial/cl/Makefile
tutorial/cpp/Makefile
tutorial/d/Makefile
tutorial/go/Makefile
@@ -865,6 +879,8 @@ if test "$have_swift" = "yes" ; then MAYBE_SWIFT="swift" ; else MAYBE_SWIFT="" ;
AC_SUBST([MAYBE_SWIFT])
if test "$have_netstd" = "yes" ; then MAYBE_NETSTD="netstd" ; else MAYBE_NETSTD="" ; fi
AC_SUBST([MAYBE_NETSTD])
+if test "$have_cl" = "yes" ; then MAYBE_CL="cl" ; else MAYBE_CL="" ; fi
+AC_SUBST([MAYBE_CL])
AC_OUTPUT
@@ -874,6 +890,7 @@ echo "$PACKAGE $VERSION"
echo
echo "Building C (GLib) Library .... : $have_c_glib"
echo "Building C++ Library ......... : $have_cpp"
+echo "Building Common Lisp Library.. : $have_cl"
echo "Building D Library ........... : $have_d"
echo "Building Dart Library ........ : $have_dart"
echo "Building .NET Standard Library : $have_netstd"
@@ -906,6 +923,12 @@ if test "$have_cpp" = "yes" ; then
echo " Build TQTcpServer (Qt5) ... : $have_qt5"
echo " C++ compiler version ...... : $($CXX --version | head -1)"
fi
+if test "$have_cl" = "yes" ; then
+ echo
+ echo "Common Lisp Library:"
+ echo " Using Common Lisp ......... : $SBCL"
+ echo " Using Common Lisp version . : $($SBCL --version)"
+fi
if test "$have_d" = "yes" ; then
echo
echo "D Library:"