summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Reiss <dreiss@apache.org>2007-12-28 18:25:33 +0000
committerDavid Reiss <dreiss@apache.org>2007-12-28 18:25:33 +0000
commit832b262acab7656ce5d5541f010c29f060580693 (patch)
tree8fecf364acbfb94a60a1bcf929f8f891e5130510 /Makefile.am
parent65704511459cdfc0f3e7d70b5008ea4e18a6f538 (diff)
downloadthrift-832b262acab7656ce5d5541f010c29f060580693.tar.gz
Thrift: Revamp build to use a single configure.ac.
Summary: Ben Maurer suggested that it would make sense for Thrift to build as a single project, with one configure.ac and multiple Makefile.am. He was also kind enough to do the heavy lifting, and this commit is the application of his patch (with minor modifications). The most significant visible change from this diff is that in order to buidl one of the thrift sub-projects (i.e.: the compiler, the C++ library, or the Python library) you must run bootstrap.sh and configure in the Thrift root, then make in the specific project. Users who want to build and install the Python library but can't run configure because they don't have Boost can simply run setup.py directly. Reviewed By: mcslee Test Plan: Built Thrift from scratch. Revert Plan: ok git-svn-id: https://svn.apache.org/repos/asf/incubator/thrift/trunk@665409 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index a71974d90..6bcb61f1b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,6 +1,7 @@
-SUBDIRS = compiler/cpp lib/cpp lib/py if
+ACLOCAL_AMFLAGS = -I ./aclocal
+
+SUBDIRS = compiler/cpp lib if
## Don't run make dist from a subversion working copy
## because it will pull in your .svn directories.
EXTRA_DIST = bootstrap.sh cleanup.sh doc test tutorial \
- thrift.el thrift.vim thrift.bnf CONTRIBUTORS LICENSE \
- lib/cocoa lib/erl lib/hs lib/java lib/ocaml lib/perl lib/php lib/rb
+ thrift.el thrift.vim thrift.bnf CONTRIBUTORS LICENSE