summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRoger Meier <roger@apache.org>2015-03-24 22:30:40 +0100
committerRoger Meier <roger@apache.org>2015-03-24 22:30:40 +0100
commit41ad4342c5a0389ab2cf2dbf098086413ac01204 (patch)
tree1ce9c7d4e70a7370f132ce5d4fd245a20a68e45e /Makefile.am
parenta2d12b6ee3d9aa66f2c16dc6a5ee6eef5f1eba92 (diff)
downloadthrift-41ad4342c5a0389ab2cf2dbf098086413ac01204.tar.gz
THRIFT-847 Test Framework harmonization across all languages
THRIFT-2946 Enhance usability of cross test framework Patch: Nobuaki Sukegawa This closes: #358
Diffstat (limited to 'Makefile.am')
-rwxr-xr-xMakefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 0a9e43180..bbe6f8034 100755
--- a/Makefile.am
+++ b/Makefile.am
@@ -37,10 +37,18 @@ dist-hook:
print-version:
@echo $(VERSION)
+.PHONY: precross cross cross2
+precross-%: all
+ $(MAKE) -C $* precross
+precross: all precross-test precross-lib
-cross: check
+cross: precross
sh test/test.sh
+# TODO: generate --server and --client switches from "--with(out)-..." build flags
+cross2: precross
+ python test/test.py -s
+
codespell_skip_files = \
*.jar \
*.class \