summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNobuaki Sukegawa <nsukeg@gmail.com>2015-04-11 23:01:40 +0900
committerRoger Meier <roger@apache.org>2015-04-12 09:58:22 +0200
commit147a5a278a71e4652edb8f60043a057f26d60d1d (patch)
treedbe8ec9ee0d1af6617a7cc39f81177ec0258f8f4 /Makefile.am
parent6d71dc868873691a62b3cb28bf48dcb0e225fa95 (diff)
downloadthrift-147a5a278a71e4652edb8f60043a057f26d60d1d.tar.gz
THRIFT-2946 Enhance usability of cross test framework
*make fail* runs test.py 4 times to detect nondeterministic failures.
Diffstat (limited to 'Makefile.am')
-rwxr-xr-xMakefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 5b60c5f5c..9ba6e8e28 100755
--- a/Makefile.am
+++ b/Makefile.am
@@ -46,9 +46,11 @@ precross: all precross-test precross-lib
cross: precross
$(PYTHON) test/test.py -s
+TIMES = 1 2 3
fail: precross
- $(PYTHON) test/test.py
+ $(PYTHON) test/test.py || true
$(PYTHON) test/test.py --update-expected-failures=overwrite
+ $(foreach var,$(TIMES),test/test.py -s || true;test/test.py --update-expected-failures=merge;)
codespell_skip_files = \
*.jar \