summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJames E. King, III <jking@apache.org>2017-09-30 15:44:16 -0700
committerJames E. King, III <jking@apache.org>2017-10-19 11:29:04 -0400
commit0ad20bdbfe9abcbb0cc5332ff95651b5c975da91 (patch)
tree7e713c9380844afe41019a7c6ebe4e508eba3464 /Makefile.am
parent8b8a8efea13d1c97f856053af0a5c0e6a8a76354 (diff)
downloadthrift-0ad20bdbfe9abcbb0cc5332ff95651b5c975da91.tar.gz
THRIFT-4351: use travis build stages to optimize build,
avoiding duplicate rebuilds of the same image, and also allow personal docker hub repositories for private fork builds to be optimized. Move ubsan build to artful image because it catches more stuff and fix what was found. THRIFT-4345: solidify docker build strategy for maximum coverage: trusty, xenial, artful as stock as they can be THRIFT-4344: add top level language summary markdown and update readme with a new image on the layered architecture THRIFT-3847: remove VERSION macro from config.h which was causing a conflict on artful builds. THRIFT-4359: fix haxe map/set decode when key is binary, as a missing break statement caused it to use an int during decode This closes #1389
Diffstat (limited to 'Makefile.am')
-rwxr-xr-xMakefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 6d4764210..4b3157c90 100755
--- a/Makefile.am
+++ b/Makefile.am
@@ -43,7 +43,7 @@ dist-hook:
find $(distdir) -type d \( -iname ".svn" -or -iname ".git" \) | xargs rm -rf
print-version:
- @echo $(VERSION)
+ @echo $(PACKAGE_VERSION)
.PHONY: precross cross
precross-%: all
@@ -123,7 +123,7 @@ EXTRA_DIST = \
doap.rdf \
package.json \
sonar-project.properties \
- Dockerfile \
+ LANGUAGES.md \
LICENSE \
CHANGES \
NOTICE \