summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorKonrad Grochowski <hcorg@apache.org>2014-11-24 11:16:54 +0100
committerKonrad Grochowski <hcorg@apache.org>2014-11-24 11:16:54 +0100
commit05fb842f6dcb5d359809a0eaaad8366bdea389f7 (patch)
treebc1b398ce370d7865b8359d764eda99cd05b257d /Makefile.am
parent3b5dacba44e4fa5c07c8b828d2f65215f9c91e34 (diff)
downloadthrift-05fb842f6dcb5d359809a0eaaad8366bdea389f7.tar.gz
THRIFT-2849: codespell added to 'make style'
Client: Build Patch: Konrad Grochowski Please remember to verifying changes before commiting
Diffstat (limited to 'Makefile.am')
-rwxr-xr-xMakefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 26ddab69a..aeff37c94 100755
--- a/Makefile.am
+++ b/Makefile.am
@@ -41,6 +41,32 @@ print-version:
cross: check
sh test/test.sh
+codespell_skip_files = \
+ *.a \
+ *.la \
+ *.o \
+ *.p12 \
+ *OCamlMakefile \
+ .keystore \
+ .truststore \
+ CHANGES \
+ config.sub \
+ configure \
+ depcomp \
+ libtool.m4 \
+ output.* \
+ rebar \
+ thrift
+
+empty :=
+space := $(empty) $(empty)
+comma := ,
+
+skipped_files = $(subst $(space),$(comma),$(codespell_skip_files))
+
+style-local:
+ codespell --write-changes --skip=$(skipped_files) --disable-colors
+
EXTRA_DIST = \
.travis.yml \
bower.json \