summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorcyy <cyyever@outlook.com>2019-02-07 22:27:33 +0800
committerJames E. King III <jking@apache.org>2019-02-07 09:27:33 -0500
commita6a3a787ec3d3bd71b276e85c9a02a53ad1105c4 (patch)
tree438428e3a319ad6de47d5ba50152e59f39b0fe1d /CMakeLists.txt
parent4a898564f936b39d45490f370737ce55d4c2b3f5 (diff)
downloadthrift-a6a3a787ec3d3bd71b276e85c9a02a53ad1105c4.tar.gz
THRIFT-4732:refine cmake scripts (#1688)
* add cmake support for clib and remove unused variables * add targets for code analysis * add wall to all compilers and add utf-8 options for msvc
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f0165f8f4..c77a6010c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -47,6 +47,9 @@ include(DefineInstallationPaths)
# Based on the options set some platform specifics
include(DefinePlatformSpecifc)
+# Add CMake targets for static code analysis
+include(StaticCodeAnalysis)
+
# Generate the config.h file
include(ConfigureChecks)
@@ -98,6 +101,9 @@ endif()
if(BUILD_C_GLIB)
add_subdirectory(${CMAKE_CURRENT_SOURCE_DIR}/lib/c_glib)
+ if(BUILD_TESTING)
+ add_subdirectory(${CMAKE_CURRENT_SOURCE_DIR}/test/c_glib)
+ endif()
endif()
if(BUILD_JAVA)