summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMario Emmenlauer <memmenlauer@biodataanalysis.de>2019-10-23 17:32:34 +0200
committerJens Geyer <jensg@apache.org>2020-04-22 21:17:33 +0200
commit93171d2482f98d77887874afc3bbb73f0bbb65c2 (patch)
treed377bd31b8cfcaae4538b72e15a2baa83dc42c24 /CMakeLists.txt
parent6064696ae08e9764f588143f8ffd380b95405aca (diff)
downloadthrift-93171d2482f98d77887874afc3bbb73f0bbb65c2.tar.gz
THRIFT-5109 Misc Cmake build improvements
Patch: Mario Emmenlauer This closes #2094
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f2e682ac2..18e52f638 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -113,6 +113,14 @@ if(BUILD_JAVA)
add_subdirectory(${CMAKE_CURRENT_SOURCE_DIR}/lib/java)
endif()
+if(BUILD_JAVASCRIPT)
+ add_subdirectory(${CMAKE_CURRENT_SOURCE_DIR}/lib/js)
+endif()
+
+if(BUILD_NODEJS)
+ add_subdirectory(${CMAKE_CURRENT_SOURCE_DIR}/lib/nodejs)
+endif()
+
if(BUILD_PYTHON)
add_subdirectory(${CMAKE_CURRENT_SOURCE_DIR}/lib/py)
if(BUILD_TESTING)