summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJiayu Liu <jiayu.liu@airbnb.com>2022-04-06 16:49:09 +0800
committerJens Geyer <jensg@apache.org>2022-04-20 23:49:33 +0200
commit49b2d6b888a2a96fc0948da81a779a90b4624170 (patch)
tree11b532385bcf72e8ea1188ed489de0c905164a42 /CMakeLists.txt
parenteac5103f8204021f7b5436001319c2b17ed5644f (diff)
downloadthrift-49b2d6b888a2a96fc0948da81a779a90b4624170.tar.gz
THRIFT-5548: add kotlin code gen
Client: kotlin Patch: Jiayu Liu This closes #2556
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e5f93cdeb..7119628b3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -113,6 +113,10 @@ if(BUILD_JAVASCRIPT)
add_subdirectory(${CMAKE_CURRENT_SOURCE_DIR}/lib/js)
endif()
+if(BUILD_KOTLIN)
+ add_subdirectory(${CMAKE_CURRENT_SOURCE_DIR}/lib/kotlin)
+endif()
+
if(BUILD_NODEJS)
add_subdirectory(${CMAKE_CURRENT_SOURCE_DIR}/lib/nodejs)
endif()