summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJames E. King, III <jim.king@simplivity.com>2017-04-04 13:04:29 -0400
committerJames E. King, III <jking@apache.org>2017-04-05 08:58:38 -0400
commit43e959bc5c4e68d0c2545a09ad4fc1c226885a22 (patch)
tree98657bcdad212f03ad340eb22890b1fc584aa51f /CMakeLists.txt
parent7f5a8c28bc58011abef0cede10915c2071efbe41 (diff)
downloadthrift-43e959bc5c4e68d0c2545a09ad4fc1c226885a22.tar.gz
THRIFT-4165: better cmake support for C++ language level selection; fixed compiler warnings
This closes #1236
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 8 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 93ed8d2ac..9f57a66c4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -17,7 +17,14 @@
# under the License.
#
-cmake_minimum_required(VERSION 2.8.12)
+cmake_minimum_required(VERSION 3.1)
+
+# CMake 3.1 supports C++ standards selection with CMAKE_CXX_STANDARD
+# If you need CMake 3.1+ for Ubuntu 14.04, try
+# https://launchpad.net/~george-edison55/+archive/ubuntu/cmake-3.x
+# If you need CMake 3.1+ for debian "jessie", get it from jessie-backports
+# Otherwise
+# http://cmake.org
project("Apache Thrift")