summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRoger Meier <roger@apache.org>2015-04-20 22:49:48 +0200
committerRoger Meier <roger@apache.org>2015-04-20 22:49:48 +0200
commit3b99c970ad0c9fa2ca009f7b00aaeb902ee9850a (patch)
treef2b0df35478a527ef5aa416b6fe96d7f62912c74 /CMakeLists.txt
parentaeb89aa81bdd23aee2f70eabe87f44d7fb2c9c8a (diff)
downloadthrift-3b99c970ad0c9fa2ca009f7b00aaeb902ee9850a.tar.gz
THRIFT-3106 CMake summary should give more information why a library is set to off
Patch: Pascal Bach This closes #454
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 386a63db9..70bdb75c4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -72,7 +72,7 @@ if(BUILD_COMPILER)
add_subdirectory(${CMAKE_CURRENT_SOURCE_DIR}/compiler/cpp)
endif()
-if(WITH_CPP)
+if(BUILD_CPP)
add_subdirectory(${CMAKE_CURRENT_SOURCE_DIR}/lib/cpp)
if(BUILD_TESTING)
if(WITH_LIBEVENT AND WITH_ZLIB AND WITH_OPENSSL)
@@ -83,15 +83,15 @@ if(WITH_CPP)
endif()
endif()
-if(WITH_C_GLIB)
+if(BUILD_C_GLIB)
add_subdirectory(${CMAKE_CURRENT_SOURCE_DIR}/lib/c_glib)
endif()
-if(WITH_JAVA)
+if(BUILD_JAVA)
add_subdirectory(${CMAKE_CURRENT_SOURCE_DIR}/lib/java)
endif()
-if(WITH_PYTHON)
+if(BUILD_PYTHON)
add_subdirectory(${CMAKE_CURRENT_SOURCE_DIR}/lib/py)
endif()