summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorNobuaki Sukegawa <nsuke@apache.org>2015-10-29 00:41:39 +0900
committerNobuaki Sukegawa <nsuke@apache.org>2015-10-29 00:41:52 +0900
commit27378fa34e616a4dc40d943fea358eb29d1dcd56 (patch)
treef6733b9b1b2c9faca7c5bbdc29c888ac37b60787 /CMakeLists.txt
parent6748993dcbd7e1b1a3cdce3b0cb3b80d24dd4a24 (diff)
downloadthrift-27378fa34e616a4dc40d943fea358eb29d1dcd56.tar.gz
THRIFT-3398 Add CMake build for Haskell library and tests
Client: Build, Haskell Patch: Nobuaki Sukegawa This closes #660
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 44f65afbf..f3005f56e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -100,4 +100,11 @@ if(BUILD_PYTHON)
endif()
endif()
+if(BUILD_HASKELL)
+ add_subdirectory(${CMAKE_CURRENT_SOURCE_DIR}/lib/hs)
+ if(BUILD_TESTING)
+ add_subdirectory(${CMAKE_CURRENT_SOURCE_DIR}/test/hs)
+ endif()
+endif()
+
PRINT_CONFIG_SUMMARY()