summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRoger Meier <roger@apache.org>2015-06-04 12:47:31 +0200
committerRoger Meier <roger@apache.org>2015-06-04 12:47:31 +0200
commit211b82de11c3c5bb83f669a95373b3ea6601d666 (patch)
tree998af03c23a903889e0185eb4503da59614ea041 /CMakeLists.txt
parent7daf00ceb1b6d52f7ab612b03f63907866381ff1 (diff)
downloadthrift-211b82de11c3c5bb83f669a95373b3ea6601d666.tar.gz
THRIFT-2850 CMake for Apache Thrift
Change project name to "Apache Thrift" and add test/py
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index afdd746f7..4db182eaa 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -19,7 +19,7 @@
cmake_minimum_required(VERSION 2.8.12)
-project(thrift)
+project("Apache Thrift")
set(CMAKE_MODULE_PATH "${CMAKE_MODULE_PATH}" "${CMAKE_CURRENT_SOURCE_DIR}/build/cmake")
@@ -92,6 +92,9 @@ endif()
if(BUILD_PYTHON)
add_subdirectory(${CMAKE_CURRENT_SOURCE_DIR}/lib/py)
+ if(BUILD_TESTING)
+ add_subdirectory(${CMAKE_CURRENT_SOURCE_DIR}/test/py)
+ endif()
endif()
PRINT_CONFIG_SUMMARY()