summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorNobuaki Sukegawa <nsuke@apache.org>2016-09-10 14:02:19 +0900
committerNobuaki Sukegawa <nsuke@apache.org>2016-09-26 01:42:01 +0900
commit11da87e6f30c237869a09e28ab44fe4a59db270e (patch)
tree4c81e09a6c5647cf8b4216379c30ec8ec2cb5517 /CMakeLists.txt
parent1e3cf9b9fdcf9a7b7ffc18a2e6148465b154e66b (diff)
downloadthrift-11da87e6f30c237869a09e28ab44fe4a59db270e.tar.gz
THRIFT-2835 Add possibility to distribute generators separately from thrift core, and load them dynamically
Client: Compiler Patch: Nobuaki Sukegawa, rebased by dtmuller Also fixed by dtmuller: * Add plugin namespace for erlang language binding * Fix unit test test_const_value * Don't clear type cache with every t_program conversion * Type "wb" may not be supported by popen on non-Windows platforms * Fix constness of AST type signatures
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 37e89766f..93ed8d2ac 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -73,6 +73,9 @@ if(BUILD_COMPILER)
set(THRIFT_COMPILER $<TARGET_FILE:thrift-compiler>)
endif()
add_subdirectory(${CMAKE_CURRENT_SOURCE_DIR}/compiler/cpp)
+elseif(EXISTS ${THRIFT_COMPILER})
+ add_executable(thrift-compiler IMPORTED)
+ set_property(TARGET thrift-compiler PROPERTY IMPORTED_LOCATION ${THRIFT_COMPILER})
endif()
if(BUILD_CPP)