summaryrefslogtreecommitdiff
path: root/install-info/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'install-info/Makefile.am')
-rw-r--r--install-info/Makefile.am31
1 files changed, 31 insertions, 0 deletions
diff --git a/install-info/Makefile.am b/install-info/Makefile.am
new file mode 100644
index 0000000..d81a48b
--- /dev/null
+++ b/install-info/Makefile.am
@@ -0,0 +1,31 @@
+# $Id: Makefile.am,v 1.1 2008/01/02 01:36:16 karl Exp $
+# Makefile.am for texinfo/install-info.
+# Run automake in .. to produce Makefile.in from this.
+#
+# This file is free software; as a special exception the author gives
+# unlimited permission to copy and/or distribute it, with or without
+# modifications, as long as this notice is preserved.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY, to the extent permitted by law; without even the
+# implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
+
+SUBDIRS = tests
+bin_PROGRAMS = ginstall-info
+
+# Use `ginstall-info' in the definition of PROGRAMS and in dependencies
+# because automake generates an install-info target in every Makefile
+# (this is easier than changing Automake.)
+ginstall_info_SOURCES = install-info.c
+
+# Transform `ginstall-info' to `install-info' before applying any
+# user-specified name transformations.
+transform = s/ginstall-info/install-info/; $(program_transform_name)
+
+localedir = $(datadir)/locale
+AM_CPPFLAGS = \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/gnulib/lib \
+ -I$(top_builddir)/gnulib/lib \
+ -DLOCALEDIR=\"$(localedir)\"
+LDADD = ../lib/libtxi.a $(top_builddir)/gnulib/lib/libgnu.a $(LIBINTL)