summaryrefslogtreecommitdiff
path: root/telepathy-logger/channel-text.c
Commit message (Collapse)AuthorAgeFilesLines
* Renamed TplChannelText into TplTextChannelNicolas Dufresne2011-02-081-1353/+0
| | | | | This renames the subclass in a more natural and more traditional way as found in many other GObject based APIs.
* Renamed TplEventText into TplTextEventNicolas Dufresne2011-02-081-15/+14
| | | | | This renames the subclass in a more natural and more traditional way as found in many other GObject based APIs.
* Fix missing space before parenthesisNicolas Dufresne2011-02-081-1/+1
|
* Remove useless scope variableNicolas Dufresne2011-02-081-3/+2
|
* Use gchar instead of charNicolas Dufresne2011-02-081-1/+1
|
* Refactored TplEvent/TplEventTextNicolas Dufresne2011-02-071-104/+119
| | | | | | | | Enforces using g_object_new() instead of the partial _new() method with loads of get/set. This imply removing all the get/set methods that are not strictly required, making the properties construct only and porting the rest of the code. This change also make "make check" work again. Some more cleanup is also included.
* Room can be deduced from the receiver typeNicolas Dufresne2011-02-071-6/+0
| | | | | | Rename and move is_chatroom from TplEventText to TplEvent and implement it by looking at the receiver type. Note that this breaks make check because none of the current log-store sets the receiver.
* Fix arguments naming according to conventionsNicolas Dufresne2011-02-071-33/+33
|
* Properly move pending-msg-id into TplEventTextNicolas Dufresne2011-02-071-3/+3
|
* Renmove TplEventTextSignalTypeNicolas Dufresne2011-02-071-3/+0
| | | | The reality is that we don't do anything useful with it.
* Refactored TplEntity and added unit-testNicolas Dufresne2011-01-191-53/+42
|
* Remove TplEventDirectionNicolas Dufresne2011-01-171-4/+2
| | | | | | TplEventDirection was redundant with the TplEntityType of the sender. In all cases, if the sender is SELF then it's an outgoing message, otherwise it's incoming.
* TplEvent:chat-id -> idEmilio Pozuelo Monfort2011-01-171-3/+3
|
* Renamed TplEntry* into TplEvent*Nicolas Dufresne2011-01-101-58/+58
|
* Adapt the text channel to the API changesEmilio Pozuelo Monfort2011-01-101-2/+2
|
* Move text signal types from TplEntry to TplEntryTextEmilio Pozuelo Monfort2010-12-241-2/+2
|
* More typo fixesEmilio Pozuelo Monfort2010-12-231-2/+2
|
* Handle the error instead of aborting the loggerEmilio Pozuelo Monfort2010-12-061-3/+0
| | | | https://bugs.freedesktop.org/show_bug.cgi?id=31510
* Clean up connecting to text channel signals.Will Thompson2010-10-131-52/+25
| | | | | | | | | | | There's really no point in logging which signal we failed to connect to, because the reason will always be the same: the object is invalidated, or the interface in question isn't implemented. Plus, there's no point in trying to carry on if we'll ultimately bail out if any errors occurred. So, let's just bail out as soon as we encounter an error connecting to a signal.
* Listen for text channel invalidation, not just ClosedWill Thompson2010-10-131-15/+13
| | | | | | | | If the CM crashes, the Closed() signal will not be emitted for a channel. This previously left the logger believing it was logging a channel, when actually it wasn't. Fixes: <https://bugs.freedesktop.org/show_bug.cgi?id=30824>
* fix TpContact leak (#28903)Guillaume Desmottes2010-07-051-1/+1
|
* always pass a weak pointer to tp_connection_get_contacts_by_handleGuillaume Desmottes2010-07-051-1/+2
|
* Don't cleanup stale log-ids when preparing text channelsGuillaume Desmottes2010-06-281-0/+7
| | | | | | | | | This takes a while as it involves lot of SQL comments and slow down the dispatching of channels (fdo #28787). According documentation of this function that's just an optionnal optimisation so disabling it won't hurt. I opened fdo #28791 about remaning issues in this code.
* use the channel specific handle if anyGuillaume Desmottes2010-06-281-3/+9
|
* use tp_value_array_unpackGuillaume Desmottes2010-06-231-7/+7
|
* wrap big linesGuillaume Desmottes2010-06-231-11/+16
|
* get_self_contact_cb: no need to get the observerGuillaume Desmottes2010-06-231-3/+0
|
* Simplfy settings of chatrooms infoGuillaume Desmottes2010-06-231-110/+32
|
* No more need to get the remote contact separatelyGuillaume Desmottes2010-06-231-63/+3
| | | | | This is done in pendingproc_get_remote_contacts() now. That also allow us to remove this bong selector thing.
* on_sent_signal_cb: use the contacts cacheGuillaume Desmottes2010-06-231-13/+7
|
* Use the contacts cache when receiving a messageGuillaume Desmottes2010-06-231-6/+8
| | | | Also update the cache if the sender wasn't in the cache.
* channel-text: cache TpContact of participants (fdo #28680)Guillaume Desmottes2010-06-231-1/+119
|
* on_received_signal_with_contact_cb: no need to set the remote contactGuillaume Desmottes2010-06-231-4/+0
| | | | | In the 1-1 case we already set it when preparing the channel so this was never called.
* remove unused functions from the internal APIGuillaume Desmottes2010-06-231-47/+36
| | | | Also reorder some static functions so we don't need prototypes.
* rename pendingproc_connect_signals to pendingproc_connect_message_signalsGuillaume Desmottes2010-06-231-3/+3
|
* Wait that we get contacts before connecting signalsGuillaume Desmottes2010-06-231-1/+1
| | | | Callback of these signals assume that contacts have been retrieved.
* remove useless prototypesGuillaume Desmottes2010-06-231-8/+0
|
* entry: replace the 'account-path' property by the TpAccount itselfGuillaume Desmottes2010-06-231-6/+4
| | | | | Strictly speaking this is a API break but Empathy doesn't use this property and I kept the tpl_entry_get_account_path() method.
* Don't use remote contact as sender in chatroomsGuillaume Desmottes2010-06-231-16/+24
| | | | | As said in a comment, the remote contact is only meant to be used for 1-1 chat, not chatrooms.
* don't log messages with the Rescued flagGuillaume Desmottes2010-06-171-0/+6
|
* set the right entity type on self entitiesGuillaume Desmottes2010-06-151-2/+2
|
* rename TPL_ENTITY_USER to TPL_ENTITY_CONTACTGuillaume Desmottes2010-06-151-4/+4
|
* rename TplContact to TplEntityGuillaume Desmottes2010-06-151-40/+40
|
* move contact(-internal) to entity(-internal)Guillaume Desmottes2010-06-151-1/+1
|
* rename tpl_entry_get_pending_msg_id to tpl_entry_text_get_pending_msg_idGuillaume Desmottes2010-06-091-2/+2
|
* rename TplLogEntryText to TplEntryText and TplLogEntry to TplEntryGuillaume Desmottes2010-06-071-55/+55
|
* move log-entry(-text) to entry(-text)Guillaume Desmottes2010-06-071-3/+3
|
* move tpl_log_entry_get_log_id as internal APIGuillaume Desmottes2010-06-041-1/+1
|
* observer: prefix internal API with underscoreGuillaume Desmottes2010-06-041-3/+3
|
* log-store-sqlite: prefix internal API with underscoreGuillaume Desmottes2010-06-041-12/+12
|