summaryrefslogtreecommitdiff
path: root/telepathy-logger/channel-text.c
Commit message (Expand)AuthorAgeFilesLines
* Renamed TplChannelText into TplTextChannelNicolas Dufresne2011-02-081-1353/+0
* Renamed TplEventText into TplTextEventNicolas Dufresne2011-02-081-15/+14
* Fix missing space before parenthesisNicolas Dufresne2011-02-081-1/+1
* Remove useless scope variableNicolas Dufresne2011-02-081-3/+2
* Use gchar instead of charNicolas Dufresne2011-02-081-1/+1
* Refactored TplEvent/TplEventTextNicolas Dufresne2011-02-071-104/+119
* Room can be deduced from the receiver typeNicolas Dufresne2011-02-071-6/+0
* Fix arguments naming according to conventionsNicolas Dufresne2011-02-071-33/+33
* Properly move pending-msg-id into TplEventTextNicolas Dufresne2011-02-071-3/+3
* Renmove TplEventTextSignalTypeNicolas Dufresne2011-02-071-3/+0
* Refactored TplEntity and added unit-testNicolas Dufresne2011-01-191-53/+42
* Remove TplEventDirectionNicolas Dufresne2011-01-171-4/+2
* TplEvent:chat-id -> idEmilio Pozuelo Monfort2011-01-171-3/+3
* Renamed TplEntry* into TplEvent*Nicolas Dufresne2011-01-101-58/+58
* Adapt the text channel to the API changesEmilio Pozuelo Monfort2011-01-101-2/+2
* Move text signal types from TplEntry to TplEntryTextEmilio Pozuelo Monfort2010-12-241-2/+2
* More typo fixesEmilio Pozuelo Monfort2010-12-231-2/+2
* Handle the error instead of aborting the loggerEmilio Pozuelo Monfort2010-12-061-3/+0
* Clean up connecting to text channel signals.Will Thompson2010-10-131-52/+25
* Listen for text channel invalidation, not just ClosedWill Thompson2010-10-131-15/+13
* fix TpContact leak (#28903)Guillaume Desmottes2010-07-051-1/+1
* always pass a weak pointer to tp_connection_get_contacts_by_handleGuillaume Desmottes2010-07-051-1/+2
* Don't cleanup stale log-ids when preparing text channelsGuillaume Desmottes2010-06-281-0/+7
* use the channel specific handle if anyGuillaume Desmottes2010-06-281-3/+9
* use tp_value_array_unpackGuillaume Desmottes2010-06-231-7/+7
* wrap big linesGuillaume Desmottes2010-06-231-11/+16
* get_self_contact_cb: no need to get the observerGuillaume Desmottes2010-06-231-3/+0
* Simplfy settings of chatrooms infoGuillaume Desmottes2010-06-231-110/+32
* No more need to get the remote contact separatelyGuillaume Desmottes2010-06-231-63/+3
* on_sent_signal_cb: use the contacts cacheGuillaume Desmottes2010-06-231-13/+7
* Use the contacts cache when receiving a messageGuillaume Desmottes2010-06-231-6/+8
* channel-text: cache TpContact of participants (fdo #28680)Guillaume Desmottes2010-06-231-1/+119
* on_received_signal_with_contact_cb: no need to set the remote contactGuillaume Desmottes2010-06-231-4/+0
* remove unused functions from the internal APIGuillaume Desmottes2010-06-231-47/+36
* rename pendingproc_connect_signals to pendingproc_connect_message_signalsGuillaume Desmottes2010-06-231-3/+3
* Wait that we get contacts before connecting signalsGuillaume Desmottes2010-06-231-1/+1
* remove useless prototypesGuillaume Desmottes2010-06-231-8/+0
* entry: replace the 'account-path' property by the TpAccount itselfGuillaume Desmottes2010-06-231-6/+4
* Don't use remote contact as sender in chatroomsGuillaume Desmottes2010-06-231-16/+24
* don't log messages with the Rescued flagGuillaume Desmottes2010-06-171-0/+6
* set the right entity type on self entitiesGuillaume Desmottes2010-06-151-2/+2
* rename TPL_ENTITY_USER to TPL_ENTITY_CONTACTGuillaume Desmottes2010-06-151-4/+4
* rename TplContact to TplEntityGuillaume Desmottes2010-06-151-40/+40
* move contact(-internal) to entity(-internal)Guillaume Desmottes2010-06-151-1/+1
* rename tpl_entry_get_pending_msg_id to tpl_entry_text_get_pending_msg_idGuillaume Desmottes2010-06-091-2/+2
* rename TplLogEntryText to TplEntryText and TplLogEntry to TplEntryGuillaume Desmottes2010-06-071-55/+55
* move log-entry(-text) to entry(-text)Guillaume Desmottes2010-06-071-3/+3
* move tpl_log_entry_get_log_id as internal APIGuillaume Desmottes2010-06-041-1/+1
* observer: prefix internal API with underscoreGuillaume Desmottes2010-06-041-3/+3
* log-store-sqlite: prefix internal API with underscoreGuillaume Desmottes2010-06-041-12/+12