summaryrefslogtreecommitdiff
path: root/extensions/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'extensions/Makefile.am')
-rw-r--r--extensions/Makefile.am42
1 files changed, 20 insertions, 22 deletions
diff --git a/extensions/Makefile.am b/extensions/Makefile.am
index 61ba12d..bac6ce9 100644
--- a/extensions/Makefile.am
+++ b/extensions/Makefile.am
@@ -2,15 +2,16 @@ tools_dir = $(top_srcdir)/tools
EXTRA_DIST = \
all.xml \
- Telepathy_Logger.xml
+ Logger.xml \
+ $(NULL)
-noinst_LTLIBRARIES = libtelepathy-logger-extensions.la
+noinst_LTLIBRARIES = libtpl-extensions.la
-libtelepathy_logger_extensions_la_SOURCES = \
+libtpl_extensions_la_SOURCES = \
extensions.c \
extensions.h
-nodist_libtelepathy_logger_extensions_la_SOURCES = \
+nodist_libtpl_extensions_la_SOURCES = \
_gen/signals-marshal.c \
_gen/signals-marshal.h \
_gen/signals-marshal.list \
@@ -24,13 +25,12 @@ nodist_libtelepathy_logger_extensions_la_SOURCES = \
BUILT_SOURCES = \
_gen/all.xml \
- $(nodist_libtelepathy_logger_extensions_la_SOURCES) \
- extensions.html
+ $(nodist_libtpl_extensions_la_SOURCES)
CLEANFILES = $(BUILT_SOURCES)
-AM_CFLAGS = $(ERROR_CFLAGS) @DBUS_CFLAGS@ @GLIB_CFLAGS@ @TP_GLIB_CFLAGS@ @HANDLE_LEAK_DEBUG_CFLAGS@
-AM_LDFLAGS = @DBUS_LIBS@ @GLIB_LIBS@ @TP_GLIB_LIBS@
+AM_CFLAGS = $(ERROR_CFLAGS) @LIBTPL_CFLAGS@ @HANDLE_LEAK_DEBUG_CFLAGS@
+AM_LDFLAGS = @LIBTPL_LIBS@
# Generated stuff
@@ -39,24 +39,22 @@ XSLTPROCFLAGS = --nonet --novalid
_gen/all.xml: all.xml $(wildcard *.xml) Makefile.am
@$(mkdir_p) _gen
- $(AM_V_GEN)$(PYTHON) $(tools_dir)/xincludator.py \
- $< > $@.tmp && mv $@.tmp $@
-
-extensions.html: _gen/all.xml $(tools_dir)/doc-generator.xsl Makefile.am
- $(AM_V_GEN)$(XSLTPROC) $(XSLTPROCFLAGS) \
- --param "allow-undefined-interfaces" "true()" \
- $(tools_dir)/doc-generator.xsl \
+ $(AM_V_GEN)$(XSLTPROC) $(XSLTPROCFLAGS) --xinclude $(tools_dir)/identity.xsl \
$< > $@
+doc/index.html: _gen/all.xml $(tools_dir)/specparser.py $(tools_dir)/doc-generator.py Makefile.am
+ $(AM_V_GEN)$(PYTHON) $(tools_dir)/doc-generator.py all.xml doc/ \
+ telepathy-spec org.freedesktop.Telepathy
+
_gen/svc.c _gen/svc.h: _gen/all.xml $(tools_dir)/glib-ginterface-gen.py \
Makefile.am
$(AM_V_GEN)$(PYTHON) $(tools_dir)/glib-ginterface-gen.py \
- --filename=_gen/svc --signal-marshal-prefix=_gabble_ext \
+ --filename=_gen/svc --signal-marshal-prefix=_tpl_ext \
--include='<telepathy-glib/dbus.h>' \
--include='"_gen/signals-marshal.h"' \
--allow-unstable \
--not-implemented-func='tp_dbus_g_method_return_not_implemented' \
- $< Gabble_Svc_
+ $< Tpl_Svc_
_gen/signals-marshal.list: _gen/all.xml \
$(tools_dir)/glib-signals-marshal-gen.py \
@@ -64,23 +62,23 @@ _gen/signals-marshal.list: _gen/all.xml \
$(AM_V_GEN)$(PYTHON) $(tools_dir)/glib-signals-marshal-gen.py $< > $@
_gen/signals-marshal.h: _gen/signals-marshal.list Makefile.am
- $(AM_V_GEN)$(GLIB_GENMARSHAL) --header --prefix=_gabble_ext_marshal $< > $@
+ $(AM_V_GEN)$(GLIB_GENMARSHAL) --header --prefix=_tpl_ext_marshal $< > $@
_gen/signals-marshal.c: _gen/signals-marshal.list Makefile.am
$(AM_V_GEN){ echo '#include "_gen/signals-marshal.h"' && \
- $(GLIB_GENMARSHAL) --body --prefix=_gabble_ext_marshal $< ; } > $@
+ $(GLIB_GENMARSHAL) --body --prefix=_tpl_ext_marshal $< ; } > $@
_gen/enums.h: _gen/all.xml $(tools_dir)/c-constants-gen.py \
Makefile.am
- $(AM_V_GEN)$(PYTHON) $(tools_dir)/c-constants-gen.py Gabble $< > $@
+ $(AM_V_GEN)$(PYTHON) $(tools_dir)/c-constants-gen.py Tpl $< > $@
_gen/interfaces.h _gen/interfaces-body.h: _gen/all.xml \
$(tools_dir)/glib-interfaces-gen.py \
Makefile.am
$(AM_V_GEN)$(PYTHON) $(tools_dir)/glib-interfaces-gen.py \
- Gabble _gen/interfaces-body.h _gen/interfaces.h $<
+ Tpl _gen/interfaces-body.h _gen/interfaces.h $<
_gen/gtypes.h _gen/gtypes-body.h: _gen/all.xml \
$(tools_dir)/glib-gtypes-generator.py Makefile.am
$(AM_V_GEN)$(PYTHON) $(tools_dir)/glib-gtypes-generator.py \
- $< _gen/gtypes Gabble
+ $< _gen/gtypes Tpl