summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorCosimo Alfarano <cosimo.alfarano@collabora.co.uk>2010-02-01 15:38:10 +0000
committerCosimo Alfarano <cosimo.alfarano@collabora.co.uk>2010-02-01 15:38:10 +0000
commitf08161df2b0e9f46271a5bb3ba5a15694642b169 (patch)
tree47342081c0b14ff6151fa3347335bfbbed5af8b7 /tests/Makefile.am
parentf9e7d06dfb68dceb66fa7abac603a621e02198d9 (diff)
downloadtelepathy-logger-f08161df2b0e9f46271a5bb3ba5a15694642b169.tar.gz
imported tests from telepathy-gabble
* test folder imported from telepathy-gabble, twisted/ still not working but cleaned-up of clearly useless tests. it still needs a further clean-up and adaptation in order to be used. * basic C tests written * autotools (configure and Makefile .au) updated for Python and Twisted checking. * autotools (configure and Makefile .au) updated for DBus and DBus-glib basic requirement
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am48
1 files changed, 48 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
new file mode 100644
index 0000000..96ae708
--- /dev/null
+++ b/tests/Makefile.am
@@ -0,0 +1,48 @@
+if WANT_TWISTED_TESTS
+CHECKTWISTED = twisted
+endif
+
+#SUBDIRS = $(CHECKTWISTED) suppressions
+
+noinst_PROGRAMS = \
+ test-tpl-channel \
+ test-tpl-conf \
+ test-tpl-log-entry \
+ test-tpl-observer
+
+LDADD = \
+ $(top_builddir)/telepathy-logger/libtelepathy-logger.la \
+ $(LIBTPL_LIBS)
+
+AM_CFLAGS = $(ERROR_CFLAGS) $(LIBTPL_CFLAGS) \
+ -I $(top_srcdir)/telepathy-logger -I $(top_builddir)/src
+
+TESTS = $(noinst_PROGRAMS)
+
+TESTS_ENVIRONMENT = G_DEBUG=fatal-warnings,fatal-criticals
+
+check-valgrind: $(TESTS)
+ G_SLICE=always-malloc \
+ G_DEBUG=gc-friendly \
+ $(MAKE) \
+ TESTS_ENVIRONMENT="$(TESTS_ENVIRONMENT) \
+ libtool --mode=execute valgrind \
+ --leak-check=full \
+ --show-reachable=no \
+ --gen-suppressions=all \
+ --num-callers=20 \
+ --suppressions=@abs_top_srcdir@/tests/suppressions/gabble.supp \
+ --suppressions=@abs_top_srcdir@/tests/suppressions/tp-glib.supp \
+ --error-exitcode=1" \
+ check-TESTS
+
+check_c_sources = \
+ $(dbus_test_sources) \
+ tpl-channel-child.c \
+ test-tpl-channel.c \
+ test-tpl-conf.c \
+ test-tpl-log-entry.c \
+ test-tpl-observer.c
+
+include $(top_srcdir)/tools/check-coding-style.mk
+check-local: check-coding-style