summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorCosimo Alfarano <cosimo.alfarano@collabora.co.uk>2010-02-10 12:19:58 +0000
committerCosimo Alfarano <cosimo.alfarano@collabora.co.uk>2010-02-10 12:19:58 +0000
commitd7365b09e0952a86ab8660479c259d1792029d0d (patch)
tree4eb666c60adba122776fb2cf7721b524b0dfdcbe /tests/Makefile.am
parent9e9750e3b8bd1ad10220c299ef7f62022cd1e8a5 (diff)
downloadtelepathy-logger-d7365b09e0952a86ab8660479c259d1792029d0d.tar.gz
created gtk-doc infrastructure
* created doc/ infrastructure * added several doc comments * fixed some tests
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am14
1 files changed, 9 insertions, 5 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 48e34b7..1ddabb1 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -4,6 +4,10 @@ endif
SUBDIRS = $(CHECKTWISTED) suppressions
+LDADD = \
+ $(top_builddir)/telepathy-logger/libtelepathy-logger.la \
+ $(LIBTPL_LIBS)
+
noinst_PROGRAMS = \
test-tpl-channel \
test-tpl-conf \
@@ -15,9 +19,10 @@ test_tpl_channel_SOURCES = \
test-tpl-channel.c \
tpl-channel-test.c
-LDADD = \
- $(top_builddir)/telepathy-logger/libtelepathy-logger.la \
- $(LIBTPL_LIBS)
+test_tpl_observer_SOURCES = \
+ test-tpl-observer.c \
+ tpl-channel-test.c
+
AM_CFLAGS = $(ERROR_CFLAGS) $(LIBTPL_CFLAGS) \
-I $(top_srcdir)/telepathy-logger -I $(top_builddir)/src
@@ -36,8 +41,7 @@ check-valgrind: $(TESTS)
--show-reachable=no \
--gen-suppressions=all \
--num-callers=20 \
- --suppressions=@abs_top_srcdir@/tests/suppressions/gabble.supp \
- --suppressions=@abs_top_srcdir@/tests/suppressions/tp-glib.supp \
+ --suppressions=@abs_top_srcdir@/tests/suppressions/tpl.supp \
--error-exitcode=1" \
check-TESTS