summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorSimon McVittie <simon.mcvittie@collabora.co.uk>2013-10-31 14:10:30 +0000
committerSimon McVittie <simon.mcvittie@collabora.co.uk>2013-11-07 18:22:58 +0000
commit5582f77b867ddd0b8f6abd87ee01eb19bdc2002a (patch)
tree65d2016b677bbb21d356e6a9ec9989b693424099 /tests/Makefile.am
parentece251a40c37483e20a4875f83e869c3309496cb (diff)
downloadtelepathy-logger-5582f77b867ddd0b8f6abd87ee01eb19bdc2002a.tar.gz
Use the Automake "parallel-tests" driver, albeit in non-parallel mode
This seems perverse, but it means we invoke tests in the same way I want to use for other Telepathy projects, which will help when we want to merge their source trees together. Now that we can rely on having the parallel-tests setup, we can use AM_TESTS_ENVIRONMENT instead of TESTS_ENVIRONMENT (which is now reserved for the user, like CFLAGS), and we must use LOG_COMPILER rather than TESTS_ENVIRONMENT for "adverb" command prefixes. We no longer need to use test-wrapper.sh for the tests, because Automake has similar functionality built-in. On a buildbot or similar, use "make check VERBOSE=1" to cat the logs automatically. (cherry picked from commit 09ff23c267f2b90576cb79c8d3187eda6cb435c8) Reviewed-by: Guillaume Desmottes <guillaume.desmottes@collabora.co.uk> Bug: https://bugs.freedesktop.org/show_bug.cgi?id=71100
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am10
1 files changed, 6 insertions, 4 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 436758b..83665d6 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,3 +1,7 @@
+# These tests aren't ready for parallel invocation yet: they all use
+# the same log directory.
+.NOTPARALLEL:
+
SUBDIRS = $(CHECKTWISTED) suppressions lib dbus
EXTRA_DIST = logs
@@ -19,19 +23,17 @@ AM_CFLAGS = \
-I$(top_builddir) \
$(NULL)
-TESTS_ENVIRONMENT = \
+AM_TESTS_ENVIRONMENT = \
G_DEBUG=fatal-warnings,fatal-criticals \
TPL_TEST_MODE=true \
TEST_LOG_DIR=@abs_top_srcdir@/tests/logs \
- $(top_srcdir)/tools/test-wrapper.sh \
$(NULL)
check-valgrind: $(TESTS)
G_SLICE=always-malloc \
G_DEBUG=gc-friendly \
$(MAKE) \
- TESTS_ENVIRONMENT="$(TESTS_ENVIRONMENT) \
- libtool --mode=execute valgrind \
+ LOG_COMPILER="libtool --mode=execute valgrind \
--leak-check=full \
--show-reachable=no \
--gen-suppressions=all \