summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorCosimo Alfarano <cosimo.alfarano@collabora.co.uk>2010-02-04 17:27:17 +0000
committerCosimo Alfarano <cosimo.alfarano@collabora.co.uk>2010-02-04 17:27:17 +0000
commit164d3acd8e76757d56a6e8e65f18edce0eb56a47 (patch)
tree775d973d7025f69526fe33419fc5e001281f7d88 /tests/Makefile.am
parenta68ca09705b73ea229186671e97bcddc76e51866 (diff)
downloadtelepathy-logger-164d3acd8e76757d56a6e8e65f18edce0eb56a47.tar.gz
Add support for multi logstore
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am14
1 files changed, 10 insertions, 4 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 96ae708..48e34b7 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -2,13 +2,18 @@ if WANT_TWISTED_TESTS
CHECKTWISTED = twisted
endif
-#SUBDIRS = $(CHECKTWISTED) suppressions
+SUBDIRS = $(CHECKTWISTED) suppressions
noinst_PROGRAMS = \
test-tpl-channel \
test-tpl-conf \
test-tpl-log-entry \
- test-tpl-observer
+ test-tpl-observer \
+ test-searches
+
+test_tpl_channel_SOURCES = \
+ test-tpl-channel.c \
+ tpl-channel-test.c
LDADD = \
$(top_builddir)/telepathy-logger/libtelepathy-logger.la \
@@ -38,11 +43,12 @@ check-valgrind: $(TESTS)
check_c_sources = \
$(dbus_test_sources) \
- tpl-channel-child.c \
+ tpl-channel-test.c \
test-tpl-channel.c \
test-tpl-conf.c \
test-tpl-log-entry.c \
- test-tpl-observer.c
+ test-tpl-observer.c \
+ test-searches.c
include $(top_srcdir)/tools/check-coding-style.mk
check-local: check-coding-style