summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNicolas Dufresne <nicolas.dufresne@collabora.co.uk>2011-03-24 20:26:52 -0400
committerNicolas Dufresne <nicolas.dufresne@collabora.co.uk>2011-03-25 14:03:04 -0400
commitf1f8673bea54f69765c48aa71b217865562c0095 (patch)
tree750e7684ed57fa2565477d5f2aa9453bf68147ea /configure.ac
parentfef67aaec653f183c797597dd081bfc1e00cee6e (diff)
downloadtelepathy-logger-f1f8673bea54f69765c48aa71b217865562c0095.tar.gz
Make Call support conditional to --enable-call
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 36e616c..3d7ea48 100644
--- a/configure.ac
+++ b/configure.ac
@@ -181,6 +181,18 @@ if test x$enable_debug = xyes; then
fi
AM_CONDITIONAL([ENABLE_DEBUG], [test "x$enable_debug" = xyes])
+#------------------------------------------------------------
+# Enable Call logging
+#------------------------------------------------------------
+AC_ARG_ENABLE(call,
+ AS_HELP_STRING([--enable-call],[compile with experimental Call logging support]),
+ enable_call=$enableval, enable_call=no )
+
+if test x$enable_call = xyes; then
+ AC_DEFINE(ENABLE_CALL, [], [Enable Call logging])
+fi
+AM_CONDITIONAL([ENABLE_CALL], [test "x$enable_call" = xyes])
+
# -----------------------------------------------------------
# Coding style checks
# -----------------------------------------------------------
@@ -224,5 +236,6 @@ Configure summary:
Bugreporting URL............: ${PACKAGE_BUGREPORT}
Public extensions library...: ${enable_public_extensions}
Introspection support.......: ${found_introspection}
+ Call support................: ${enable_call}
"