summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorCosimo Alfarano <cosimo.alfarano@collabora.co.uk>2009-12-04 21:14:58 -0200
committerCosimo Alfarano <cosimo.alfarano@collabora.co.uk>2009-12-04 21:14:58 -0200
commit8fb9c3d6136c533cb5f240740f357647019b22ab (patch)
treed377aa717c5df7859a962dfd051aa6a40ffb4229 /Makefile.am
parent35c657537049f36e2d6fa445008a498dde4c8423 (diff)
downloadtelepathy-logger-8fb9c3d6136c533cb5f240740f357647019b22ab.tar.gz
Completed importing and refactoring of EmpathyLogStore
* removed any call which would make TPL depending on libempathy * copied empathy-time.[hc] * added some empathy's utility function to tpl_utils.[ch] * added support for automake/autoconf using empathy's one as basis: currently TPL depends on telepathy-glib and libxmp-2.0 (and theirs deps) * added AUTHORS COPYING INSTALL README and NEWS files (empty)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am43
1 files changed, 43 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..cfcae73
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,43 @@
+SUBDIRS = tools src
+
+ACLOCAL_AMFLAGS = -I m4
+
+DISTCHECK_CONFIGURE_FLAGS = \
+ --disable-scrollkeeper \
+ --disable-schemas-install
+
+EXTRA_DIST = \
+ ChangeLog \
+ ChangeLog.old \
+ README \
+ CONTRIBUTORS \
+ autogen.sh
+
+DISTCLEANFILES = \
+ ChangeLog
+
+# Workaround broken scrollkeeper that doesn't remove its files on
+# uninstall.
+distuninstallcheck_listfiles = find . -type f -print | grep -v '^\./var/scrollkeeper'
+
+distclean-local:
+ if test "x$(srdcir)" = "x."; then :; else \
+ rm -f ChangeLog; \
+ fi
+
+ChangeLog:
+ @echo Creating $@
+ @if test -d "$(srcdir)/.git"; then \
+ (GIT_DIR=$(top_srcdir)/.git ./missing --run git log EMPATHY_2_27_1.. --stat) | fmt --split-only > $@.tmp \
+ && mv -f $@.tmp $@ \
+ || ($(RM) $@.tmp; \
+ echo Failed to generate ChangeLog, your ChangeLog may be outdated >&2; \
+ (test -f $@ || echo git-log is required to generate this file >> $@)); \
+ else \
+ test -f $@ || \
+ (echo A git checkout and git-log is required to generate ChangeLog >&2 && \
+ echo A git checkout and git-log is required to generate this file >> $@); \
+ fi
+
+.PHONY: ChangeLog
+