summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2018-01-21 19:33:54 -0800
committerGuy Harris <guy@alum.mit.edu>2018-01-21 19:33:54 -0800
commit2a3509a466d10d68dc6442187f7bf9372acef77a (patch)
tree8686c66487be044b73be2e72825674e0ef84af27 /configure.ac
parent9765b18cc4036a989dd2e52b346ac3f27f7aeb84 (diff)
downloadtcpdump-2a3509a466d10d68dc6442187f7bf9372acef77a.tar.gz
Clean up comments to reflect reality.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 14 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index b8e8958b..579c5df2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -567,9 +567,8 @@ don't.])
fi
dnl
-dnl Check for "pcap_list_datalinks()", "pcap_set_datalink()",
-dnl and "pcap_datalink_name_to_val()", and use substitute versions
-dnl if they're not present.
+dnl Check for "pcap_list_datalinks()" and use a substitute version
+dnl if it's not present.
dnl
AC_CHECK_FUNC(pcap_list_datalinks,
[
@@ -580,7 +579,11 @@ AC_CHECK_FUNC(pcap_list_datalinks,
[
AC_LIBOBJ(datalinks)
])
-AC_CHECK_FUNCS(pcap_set_datalink)
+
+dnl
+dnl Check for "pcap_datalink_name_to_val()", and use a substitute version
+dnl if it's not present.
+dnl
AC_CHECK_FUNC(pcap_datalink_name_to_val,
[
AC_DEFINE(HAVE_PCAP_DATALINK_NAME_TO_VAL, 1,
@@ -597,6 +600,13 @@ AC_CHECK_FUNC(pcap_datalink_name_to_val,
])
dnl
+dnl Check for "pcap_set_datalink()"; you can't substitute for it if
+dnl it's absent (it has hooks into libpcap), so just define the
+dnl HAVE_ value if it's there.
+dnl
+AC_CHECK_FUNCS(pcap_set_datalink)
+
+dnl
dnl Check for "pcap_breakloop()"; you can't substitute for it if
dnl it's absent (it has hooks into the live capture routines),
dnl so just define the HAVE_ value if it's there.