summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2016-03-18 13:08:39 +0200
committerSergey Poznyakoff <gray@gnu.org.ua>2016-03-18 13:08:39 +0200
commit160fb9abd208148da6fda8394abfb3b2b83875b4 (patch)
tree431f518db33e4d885d464833000a62addad84fd8 /configure.ac
parentf6ad0e4af29683cb031a1c9104f6d37be2f26b47 (diff)
downloadtar-160fb9abd208148da6fda8394abfb3b2b83875b4.tar.gz
Fix build with --enable-gcc-warnings
* configure.ac: Disable stack-protector warnings
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 0ce56dcc..91d98c23 100644
--- a/configure.ac
+++ b/configure.ac
@@ -150,6 +150,7 @@ if test "$gl_gcc_warnings" = yes; then
nw="$nw -Winline" # It's OK to not inline.
nw="$nw -Wstrict-overflow" # It's OK to optimize strictly.
nw="$nw -Wsuggest-attribute=pure" # Too many warnings for now.
+ nw="$nw -Wstack-protector"
gl_MANYWARN_ALL_GCC([ws])
gl_MANYWARN_COMPLEMENT([ws], [$ws], [$nw])
@@ -160,9 +161,10 @@ if test "$gl_gcc_warnings" = yes; then
gl_WARN_ADD([-Wno-type-limits]) # It's OK to optimize based on types.
gl_WARN_ADD([-Wno-unused-parameter]) # Too many warnings for now
gl_WARN_ADD([-Wno-format-nonliteral])
-
+
gl_WARN_ADD([-fdiagnostics-show-option])
gl_WARN_ADD([-funit-at-a-time])
+
AC_SUBST([WARN_CFLAGS])