summaryrefslogtreecommitdiff
path: root/test/fuzz-regressions/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test/fuzz-regressions/meson.build')
-rw-r--r--test/fuzz-regressions/meson.build38
1 files changed, 21 insertions, 17 deletions
diff --git a/test/fuzz-regressions/meson.build b/test/fuzz-regressions/meson.build
index de69c941ea..3a2c306492 100644
--- a/test/fuzz-regressions/meson.build
+++ b/test/fuzz-regressions/meson.build
@@ -1,19 +1,4 @@
# SPDX-License-Identifier: LGPL-2.1+
-#
-# Copyright 2018 Zbigniew Jędrzejewski-Szmek
-#
-# systemd is free software; you can redistribute it and/or modify it
-# under the terms of the GNU Lesser General Public License as published by
-# the Free Software Foundation; either version 2.1 of the License, or
-# (at your option) any later version.
-#
-# systemd is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-# Lesser General Public License for more details.
-#
-# You should have received a copy of the GNU Lesser General Public License
-# along with systemd; If not, see <http://www.gnu.org/licenses/>.
sanitize_address = custom_target(
'sanitize-address-fuzzers',
@@ -24,7 +9,26 @@ sanitize_address = custom_target(
'fuzzers',
'-Db_lundef=false -Db_sanitize=address'])
+sanitizers = [['address', sanitize_address]]
+
fuzz_regression_tests = '''
- address/fuzz-dns-packet/oss-fuzz-5465
- address/fuzz-dns-packet/issue-7888
+ fuzz-dns-packet/issue-7888
+ fuzz-dns-packet/oss-fuzz-5465
+ fuzz-journal-remote/crash-5a8f03d4c3a46fcded39527084f437e8e4b54b76
+ fuzz-journal-remote/crash-96dee870ea66d03e89ac321eee28ea63a9b9aa45
+ fuzz-journal-remote/oss-fuzz-8659
+ fuzz-journal-remote/oss-fuzz-8686
+ fuzz-unit-file/oss-fuzz-6884
+ fuzz-unit-file/oss-fuzz-6885
+ fuzz-unit-file/oss-fuzz-6886
+ fuzz-unit-file/oss-fuzz-6892
+ fuzz-unit-file/oss-fuzz-6897
+ fuzz-unit-file/oss-fuzz-6897-evverx
+ fuzz-unit-file/oss-fuzz-6908
+ fuzz-unit-file/oss-fuzz-6917
+ fuzz-unit-file/oss-fuzz-6977
+ fuzz-unit-file/oss-fuzz-6977-unminimized
+ fuzz-unit-file/oss-fuzz-7004
+ fuzz-unit-file/oss-fuzz-8064
+ fuzz-unit-file/oss-fuzz-8827
'''.split()