summaryrefslogtreecommitdiff
path: root/src/test/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/test/meson.build')
-rw-r--r--src/test/meson.build31
1 files changed, 25 insertions, 6 deletions
diff --git a/src/test/meson.build b/src/test/meson.build
index 6bb5bd629e..1db8aa107d 100644
--- a/src/test/meson.build
+++ b/src/test/meson.build
@@ -67,7 +67,7 @@ tests += [
'src/test/test-helper.c'],
[libcore,
libudev,
- libsystemd_internal],
+ libshared],
[threads,
librt,
libseccomp,
@@ -119,6 +119,7 @@ tests += [
[['src/test/test-dns-domain.c'],
[libcore,
+ libshared,
libsystemd_network],
[]],
@@ -167,7 +168,7 @@ tests += [
[]],
[['src/test/test-copy.c'],
- [libshared_static],
+ [],
[]],
[['src/test/test-sigbus.c'],
@@ -376,6 +377,17 @@ tests += [
libselinux,
libblkid]],
+ [['src/test/test-watch-pid.c',
+ 'src/test/test-helper.c'],
+ [libcore,
+ libshared],
+ [libmount,
+ threads,
+ librt,
+ libseccomp,
+ libselinux,
+ libblkid]],
+
[['src/test/test-hashmap.c',
'src/test/test-hashmap-plain.c',
test_hashmap_ordered_c],
@@ -399,6 +411,10 @@ tests += [
[],
[]],
+ [['src/test/test-procfs-util.c'],
+ [],
+ []],
+
[['src/test/test-unaligned.c'],
[],
[]],
@@ -410,7 +426,7 @@ tests += [
[libcore,
libjournal_core,
libudev_core,
- libudev_internal,
+ libudev_static,
libsystemd_network,
libshared],
[threads,
@@ -499,7 +515,6 @@ tests += [
[],
'', 'manual'],
-
[['src/test/test-cgroup-mask.c',
'src/test/test-helper.c'],
[libcore,
@@ -610,7 +625,7 @@ tests += [
[['src/test/test-udev.c'],
[libudev_core,
- libudev_internal,
+ libudev_static,
libsystemd_network,
libshared],
[threads,
@@ -761,6 +776,10 @@ tests += [
[],
[threads]],
+ [['src/libsystemd/sd-bus/test-bus-watch-bind.c'],
+ [],
+ [threads], '', 'timeout=120'],
+
[['src/libsystemd/sd-bus/test-bus-chat.c'],
[],
[threads]],
@@ -772,7 +791,7 @@ tests += [
[['src/libsystemd/sd-bus/test-bus-error.c'],
[libshared_static,
- libsystemd_internal],
+ libsystemd_static],
[]],
[['src/libsystemd/sd-bus/test-bus-track.c'],