summaryrefslogtreecommitdiff
path: root/src/systemd/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/systemd/meson.build')
-rw-r--r--src/systemd/meson.build11
1 files changed, 6 insertions, 5 deletions
diff --git a/src/systemd/meson.build b/src/systemd/meson.build
index 43fd0130b9..75435acb14 100644
--- a/src/systemd/meson.build
+++ b/src/systemd/meson.build
@@ -38,16 +38,17 @@ install_headers(
############################################################
-opts = [[],
- ['-ansi'],
- ['-std=iso9899:1990']]
+opts = [['c'],
+ ['c', '-ansi'],
+ ['c', '-std=iso9899:1990'],
+ ['c++']]
foreach header : _systemd_headers
foreach opt : opts
- name = ''.join([header] + opt)
+ name = ''.join([header, ':'] + opt)
test('cc-' + name,
check_compilation_sh,
- args : cc.cmd_array() + ['-x', 'c', '-c'] + opt +
+ args : cc.cmd_array() + ['-c', '-x'] + opt +
['-Werror', '-include',
join_paths(meson.current_source_dir(), header)])
endforeach